mirror of
https://git.in.rschanz.org/ryan77627/guix.git
synced 2024-11-07 15:36:20 -05:00
7a485d43c9
This is a followup to bb907402a6
.
* gnu/packages/patches/ruby-hydra-minimal-no-byebug.patch: New file.
11 lines
335 B
Diff
11 lines
335 B
Diff
Description: Avoid dependency on byebug to reduce package closure
|
|
significantly, see https://issues.guix.gnu.org/55997
|
|
diff --git a/lib/hydra.rb b/lib/hydra.rb
|
|
index 29fbad2..6b5058a 100644
|
|
--- a/lib/hydra.rb
|
|
+++ b/lib/hydra.rb
|
|
@@ -1,4 +1,3 @@
|
|
-require 'byebug' unless ENV['RACK_ENV'] == "production"
|
|
require 'pp'
|
|
|
|
module CoreExt
|