mirror of
https://git.in.rschanz.org/ryan77627/guix.git
synced 2024-11-07 23:46:13 -05:00
af414f34fb
Clementine has a button in the preference menu that allows downloading a binary blob to add support for Spofify. Let's remove this button. It turns out this is the only part of the code base that uses crypto++, let's remove this dependency too. * gnu/packages/music.scm (clementine)[arguments]: Remove crypto++ support. Set HAVE_SPOTIFY_DOWNLOADER to FALSE. [inputs]: Remove crypto++ input. * gnu/packages/patches/clementine-remove-crypto++-dependency.patch: New file. * gnu/local.mk (dist_patch_DATA): Add it. Signed-off-by: Leo Famulari <leo@famulari.name>
19 lines
604 B
Diff
19 lines
604 B
Diff
diff --git a/CMakeLists.txt b/CMakeLists.txt
|
|
index 3202b8b..473ecb9 100755
|
|
--- a/CMakeLists.txt
|
|
+++ b/CMakeLists.txt
|
|
@@ -279,14 +279,6 @@ optional_component(LIBPULSE ON "Pulse audio integration"
|
|
|
|
optional_component(VISUALISATIONS ON "Visualisations")
|
|
|
|
-if(NOT HAVE_SPOTIFY_BLOB AND NOT CRYPTOPP_FOUND)
|
|
- message(FATAL_ERROR "Either crypto++ must be available or the non-GPL Spotify "
|
|
- "code must be compiled in")
|
|
-elseif(CRYPTOPP_FOUND)
|
|
- set(HAVE_CRYPTOPP ON)
|
|
- set(HAVE_SPOTIFY_DOWNLOADER ON)
|
|
-endif()
|
|
-
|
|
# Find DBus if it's enabled
|
|
if (HAVE_DBUS)
|
|
find_package(Qt5 COMPONENTS DBus)
|