mirror of
https://git.in.rschanz.org/ryan77627/guix.git
synced 2024-11-08 16:06:16 -05:00
49d40e60b8
`guix lint` reports two CVEs, both are unrelated: - CVE-2018-5200: for vendor "pandora" and some 4.2.2.x version - CVE-2019-9133: windows only (I assume it it alsow relates to the "pandora" vendor, since the version the CVE refers to as "solving the issue" does not exist at KDE.) * gnu/packages/kde-multimedia.scm (kmplayer): New variable. * gnu/packages/patches/kmplayer-aarch64.patch, gnu/packages/patches/kmplayer-upstream_Fix-build-with-Qt-5.9.patch: New files. * gnu/local.mk: Add them.
42 lines
1.1 KiB
Diff
42 lines
1.1 KiB
Diff
From 3def65075c09af4961cd399e8e78ed78cca72e65 Mon Sep 17 00:00:00 2001
|
|
From: Wolfgang Bauer <wbauer@tmo.at>
|
|
Date: Wed, 11 Oct 2017 22:16:02 +0200
|
|
Subject: [PATCH] Fix build with Qt 5.9
|
|
|
|
Summary:
|
|
moc 5.9 errors out when building:
|
|
Error: Plugin Metadata file "" could not be opened: file to open is a directory
|
|
|
|
Same issue and fix as https://phabricator.kde.org/D5392 for khtml.
|
|
|
|
CCBUG: 377490
|
|
|
|
Test Plan: builds fine now with Qt 5.9.0rc and also earlier versions.
|
|
|
|
Reviewers: vriezen, pino
|
|
|
|
Reviewed By: pino
|
|
|
|
Subscribers: pino
|
|
|
|
Differential Revision: https://phabricator.kde.org/D5985
|
|
---
|
|
src/kmplayer_part.h | 2 +-
|
|
1 file changed, 1 insertion(+), 1 deletion(-)
|
|
|
|
diff --git a/src/kmplayer_part.h b/src/kmplayer_part.h
|
|
index f90f85d..0fddbaa 100644
|
|
--- a/src/kmplayer_part.h
|
|
+++ b/src/kmplayer_part.h
|
|
@@ -36,7 +36,7 @@ namespace KMPlayer {
|
|
|
|
class KMPlayerFactory : public KPluginFactory {
|
|
Q_OBJECT
|
|
- Q_PLUGIN_METADATA(IID "org.kde.KPluginFactory" FILE "")
|
|
+ Q_PLUGIN_METADATA(IID "org.kde.KPluginFactory")
|
|
Q_INTERFACES(KPluginFactory)
|
|
public:
|
|
KMPlayerFactory();
|
|
--
|
|
2.14.2
|
|
|