mirror of
https://git.in.rschanz.org/ryan77627/guix.git
synced 2024-12-27 06:42:14 -05:00
b44b2e346c
This also updates the qnnpack-pytorch package. * gnu/packages/machine-learning.scm (%python-pytorch-version): Set to 2.4.0. (%python-pytorch-src): Adjust hash accordingly. [source]: Remove obsolete file deletions in snippet. (python-pytorch)[arguments]<#:phases>: Disable telemetry and set Python install directory. Remove obsolete USE_FFMPEG, USE_OPENCV and USE_PYTORCH_QNNPACK environment variables. [native-inputs]: Remove python-typing-extensions. [inputs]: Add brotli, cpp-httplib and zlib. Remove qnnpack. Use oneapi-dnnl, qnnpack-pytorch and xnnpack for all systems. [propagated-inputs]: Add onnx and python-typing-extensions. Use cpuinfo for all systems. [supported-systems]: New field. (python-pytorch-for-r-torch)[inputs]: Add qnnpack. * gnu/packages/patches/python-pytorch-fix-codegen.patch: Adjust patch. * gnu/packages/patches/python-pytorch-runpath.patch: Adjust patch. * gnu/packages/patches/python-pytorch-system-libraries.patch: Adjust patch. * gnu/packages/patches/python-pytorch-without-kineto.patch: Adjust patch.
64 lines
2.1 KiB
Diff
64 lines
2.1 KiB
Diff
Even when building without Kineto, the <ActivityType.h> header is still
|
|
imported and the ActivityType type is used. This patch was copied from
|
|
https://github.com/pytorch/pytorch/pull/111048 and adapted.
|
|
|
|
diff --git a/torch/csrc/profiler/kineto_shim.h b/torch/csrc/profiler/kineto_shim.h
|
|
index 7a3b788..7f49d18 100644
|
|
--- a/torch/csrc/profiler/kineto_shim.h
|
|
+++ b/torch/csrc/profiler/kineto_shim.h
|
|
@@ -12,7 +12,55 @@
|
|
#undef USE_KINETO
|
|
#endif
|
|
|
|
+#ifdef USE_KINETO
|
|
#include <ActivityType.h>
|
|
+#else
|
|
+namespace libkineto {
|
|
+// copied from header
|
|
+/*
|
|
+ * Copyright (c) Meta Platforms, Inc. and affiliates.
|
|
+ * All rights reserved.
|
|
+ *
|
|
+ * This source code is licensed under the BSD-style license found in the
|
|
+ * LICENSE file in the root directory of this source tree.
|
|
+ */
|
|
+
|
|
+// Note : All activity types are not enabled by default. Please add them
|
|
+// at correct position in the enum
|
|
+enum class ActivityType {
|
|
+ // Activity types enabled by default
|
|
+ CPU_OP = 0, // cpu side ops
|
|
+ USER_ANNOTATION,
|
|
+ GPU_USER_ANNOTATION,
|
|
+ GPU_MEMCPY,
|
|
+ GPU_MEMSET,
|
|
+ CONCURRENT_KERNEL, // on-device kernels
|
|
+ EXTERNAL_CORRELATION,
|
|
+ CUDA_RUNTIME, // host side cuda runtime events
|
|
+ CUDA_DRIVER, // host side cuda driver events
|
|
+ CPU_INSTANT_EVENT, // host side point-like events
|
|
+ PYTHON_FUNCTION,
|
|
+ OVERHEAD, // CUPTI induced overhead events sampled from its overhead API.
|
|
+
|
|
+ // Optional Activity types
|
|
+ CUDA_SYNC, // synchronization events between runtime and kernels
|
|
+ GLOW_RUNTIME, // host side glow runtime events
|
|
+ MTIA_RUNTIME, // host side MTIA runtime events
|
|
+ CUDA_PROFILER_RANGE, // CUPTI Profiler range for performance metrics
|
|
+ MTIA_CCP_EVENTS, // MTIA ondevice CCP events
|
|
+ HPU_OP, // HPU host side runtime event
|
|
+ XPU_RUNTIME, // host side xpu runtime events
|
|
+ MTIA_WORKLOADD,
|
|
+
|
|
+ PRIVATEUSE1_RUNTIME,
|
|
+ PRIVATEUSE1_DRIVER,
|
|
+
|
|
+ ENUM_COUNT, // This is to add buffer and not used for any profiling logic. Add your new type before it.
|
|
+ OPTIONAL_ACTIVITY_TYPE_START = CUDA_SYNC,
|
|
+};
|
|
+}
|
|
+
|
|
+#endif
|
|
|
|
#include <torch/csrc/Export.h>
|
|
#include <torch/csrc/profiler/api.h>
|