mirror of
https://git.in.rschanz.org/ryan77627/guix.git
synced 2025-01-20 17:53:26 -05:00
389b5b5359
* gnu/packages/java.scm (openjdk9)[source](patches): New field. * gnu/packages/patches/openjdk-9-hotspot-pointer-comparison.patch, gnu/packages/patches/openjdk-9-hotspot-stack-size.patch: New files. * gnu/local.mk (dist_patch_DATA): Adjust accordingly.
27 lines
1.3 KiB
Diff
27 lines
1.3 KiB
Diff
Avoid ordered comparison of pointer with integer to prevent compile error
|
|
with GCC 11.
|
|
|
|
diff --git a/hotspot/src/share/vm/memory/virtualspace.cpp b/hotspot/src/share/vm/memory/virtualspace.cpp
|
|
--- a/hotspot/src/share/vm/memory/virtualspace.cpp
|
|
+++ b/hotspot/src/share/vm/memory/virtualspace.cpp
|
|
@@ -581,7 +581,7 @@ ReservedHeapSpace::ReservedHeapSpace(size_t size, size_t alignment, bool large)
|
|
assert(markOopDesc::encode_pointer_as_mark(&_base[size])->decode_pointer() == &_base[size],
|
|
"area must be distinguishable from marks for mark-sweep");
|
|
|
|
- if (base() > 0) {
|
|
+ if (base() != NULL) {
|
|
MemTracker::record_virtual_memory_type((address)base(), mtJavaHeap);
|
|
}
|
|
}
|
|
diff --git a/hotspot/src/share/vm/opto/lcm.cpp b/hotspot/src/share/vm/opto/lcm.cpp
|
|
--- a/hotspot/src/share/vm/opto/lcm.cpp
|
|
+++ b/hotspot/src/share/vm/opto/lcm.cpp
|
|
@@ -39,7 +39,7 @@
|
|
// Check whether val is not-null-decoded compressed oop,
|
|
// i.e. will grab into the base of the heap if it represents NULL.
|
|
static bool accesses_heap_base_zone(Node *val) {
|
|
- if (Universe::narrow_oop_base() > 0) { // Implies UseCompressedOops.
|
|
+ if (Universe::narrow_oop_base() != NULL) { // Implies UseCompressedOops.
|
|
if (val && val->is_Mach()) {
|
|
if (val->as_Mach()->ideal_Opcode() == Op_DecodeN) {
|
|
// This assumes all Decodes with TypePtr::NotNull are matched to nodes that
|