mirror of
https://git.in.rschanz.org/ryan77627/guix.git
synced 2025-01-01 00:52:55 -05:00
ee6bb0cc76
* gnu/packages/patches/libxml2-CVE-2015-1819.patch, gnu/packages/patches/libxml2-CVE-2015-7941-pt1.patch, gnu/packages/patches/libxml2-CVE-2015-7941-pt2.patch, gnu/packages/patches/libxml2-CVE-2015-7942-pt1.patch, gnu/packages/patches/libxml2-CVE-2015-7942-pt2.patch, gnu/packages/patches/libxml2-CVE-2015-8035.patch, gnu/packages/patches/libxml2-bug-737840.patch, gnu/packages/patches/libxml2-bug-738805.patch, gnu/packages/patches/libxml2-bug-746048.patch, gnu/packages/patches/libxml2-bug-747437.patch, gnu/packages/patches/libxml2-bug-751603.patch, gnu/packages/patches/libxml2-bug-751631.patch, gnu/packages/patches/libxml2-bug-754946.patch, gnu/packages/patches/libxml2-bug-754947.patch, gnu/packages/patches/libxml2-bug-755857.patch, gnu/packages/patches/libxml2-fix-catalog-corruption.patch, gnu/packages/patches/libxml2-id-attrs-in-xmlSetTreeDoc.patch, gnu/packages/patches/libxml2-node-sort-order-pt1.patch, gnu/packages/patches/libxml2-node-sort-order-pt2.patch: New files. * gnu-system.am (dist_patch_DATA): Add them. * gnu/packages/xml.scm (libxml2)[source]: Add patches.
46 lines
1,014 B
Diff
46 lines
1,014 B
Diff
From 8985cde70901c62d3f0f04da225e73b7344a52d7 Mon Sep 17 00:00:00 2001
|
|
From: Martin von Gagern <Martin.vGagern@gmx.net>
|
|
Date: Mon, 13 Apr 2015 16:32:14 +0800
|
|
Subject: [PATCH] xmlMemUsed is not thread-safe
|
|
|
|
For https://bugzilla.gnome.org/show_bug.cgi?id=747437
|
|
just use the mutex to protect access to those variables
|
|
---
|
|
xmlmemory.c | 14 ++++++++++++--
|
|
1 file changed, 12 insertions(+), 2 deletions(-)
|
|
|
|
diff --git a/xmlmemory.c b/xmlmemory.c
|
|
index a3dc737..f24fd6d 100644
|
|
--- a/xmlmemory.c
|
|
+++ b/xmlmemory.c
|
|
@@ -554,7 +554,12 @@ xmlMemoryStrdup(const char *str) {
|
|
|
|
int
|
|
xmlMemUsed(void) {
|
|
- return(debugMemSize);
|
|
+ int res;
|
|
+
|
|
+ xmlMutexLock(xmlMemMutex);
|
|
+ res = debugMemSize;
|
|
+ xmlMutexUnlock(xmlMemMutex);
|
|
+ return(res);
|
|
}
|
|
|
|
/**
|
|
@@ -567,7 +572,12 @@ xmlMemUsed(void) {
|
|
|
|
int
|
|
xmlMemBlocks(void) {
|
|
- return(debugMemBlocks);
|
|
+ int res;
|
|
+
|
|
+ xmlMutexLock(xmlMemMutex);
|
|
+ res = debugMemBlocks;
|
|
+ xmlMutexUnlock(xmlMemMutex);
|
|
+ return(res);
|
|
}
|
|
|
|
#ifdef MEM_LIST
|
|
--
|
|
2.6.3
|
|
|