mirror of
https://git.in.rschanz.org/ryan77627/guix.git
synced 2024-11-07 23:46:13 -05:00
95024494f3
* gnu/packages/games.scm (bsd-games): New variable. New patches, taken from Arch and Debian: * gnu/packages/patches/bsd-games-2.17-64bit.patch * gnu/packages/patches/bsd-games-bad-ntohl-cast.patch * gnu/packages/patches/bsd-games-gamescreen.h.patch * gnu/packages/patches/bsd-games-getline.patch * gnu/packages/patches/bsd-games-null-check.patch * gnu/packages/patches/bsd-games-number.c-and-test.patch * gnu/packages/patches/bsd-games-prevent-name-collisions.patch * gnu/packages/patches/bsd-games-stdio.h.patch New patches with our customizations (configure-config built after Arch's): * gnu/packages/patches/bsd-games-add-configure-config.patch * gnu/packages/patches/bsd-games-add-wrapper.patch * gnu/packages/patches/bsd-games-dont-install-empty-files.patch Signed-off-by: Nicolas Goaziou <mail@nicolasgoaziou.fr>
22 lines
545 B
Diff
22 lines
545 B
Diff
diff --git a/hunt/hunt/playit.c b/hunt/hunt/playit.c
|
|
index 9acf86e..881a4e7 100644
|
|
--- a/hunt/hunt/playit.c
|
|
+++ b/hunt/hunt/playit.c
|
|
@@ -114,7 +114,7 @@ playit()
|
|
bad_con();
|
|
/* NOTREACHED */
|
|
}
|
|
- if (ntohl(version) != (unsigned long)HUNT_VERSION) {
|
|
+ if (ntohl(version) != (uint32_t)HUNT_VERSION) {
|
|
bad_ver();
|
|
/* NOTREACHED */
|
|
}
|
|
@@ -649,7 +649,7 @@ do_message()
|
|
bad_con();
|
|
/* NOTREACHED */
|
|
}
|
|
- if (ntohl(version) != (unsigned long)HUNT_VERSION) {
|
|
+ if (ntohl(version) != (uint32_t)HUNT_VERSION) {
|
|
bad_ver();
|
|
/* NOTREACHED */
|
|
}
|