mirror of
https://git.in.rschanz.org/ryan77627/guix.git
synced 2024-11-08 07:56:16 -05:00
332568d3e8
Upstream’s fix is incomplete and thus commit
7871447cf5
was insufficient.
* gnu/packages/patches/r-mixedpower-r2power.patch: New file.
* gnu/local.mk (dist_patch_DATA): Add it.
* gnu/packages/statistics.scm (r-mixedpower)[source]: Use it.
26 lines
791 B
Diff
26 lines
791 B
Diff
From e882fda905150649aa887c72731144330ca297b5 Mon Sep 17 00:00:00 2001
|
|
From: Lars-Dominik Braun <lars@6xq.net>
|
|
Date: Fri, 28 Oct 2022 09:18:11 +0200
|
|
Subject: [PATCH] Fix R2power with R>=4.2
|
|
|
|
The previous commit missed this if statement.
|
|
---
|
|
R/meta_functions.R | 2 +-
|
|
1 file changed, 1 insertion(+), 1 deletion(-)
|
|
|
|
diff --git a/R/meta_functions.R b/R/meta_functions.R
|
|
index a65f0c1..fb3feba 100644
|
|
--- a/R/meta_functions.R
|
|
+++ b/R/meta_functions.R
|
|
@@ -172,7 +172,7 @@ R2power <- function(model, data, fixed_effects, simvar,
|
|
} # end if databased
|
|
|
|
# 2. SESOI
|
|
- suppressWarnings(if (SESOI != F){ # supress warning generated by if statement if SESOI =! F
|
|
+ suppressWarnings(if (!is.logical(SESOI)){
|
|
|
|
# change beta coeficients to SESOI values
|
|
model@beta <- SESOI
|
|
--
|
|
2.37.4
|
|
|