mirror of
https://git.in.rschanz.org/ryan77627/guix.git
synced 2024-11-08 07:56:16 -05:00
46bbdef247
* gnu/packages/patches/bitcoin-core-python-compat.patch: New file. * gnu/local.mk (dist_patch_DATA): Adjust accordingly. * gnu/packages/finance.scm (bitcoin-core)[source](patches): New field.
28 lines
1.3 KiB
Diff
28 lines
1.3 KiB
Diff
Get rid of deprecation warning emitted by Python 3.8, which causes a test failure(!).
|
|
|
|
https://github.com/bitcoin/bitcoin/pull/17931
|
|
|
|
Taken from upstream:
|
|
|
|
https://github.com/bitcoin/bitcoin/commit/f117fb00da747147cddfb071c1427a2754c278cd
|
|
|
|
diff --git a/test/functional/p2p_invalid_messages.py b/test/functional/p2p_invalid_messages.py
|
|
index 20864881c165..07eacf410d88 100755
|
|
--- a/test/functional/p2p_invalid_messages.py
|
|
+++ b/test/functional/p2p_invalid_messages.py
|
|
@@ -145,13 +145,13 @@ def run_test(self):
|
|
def test_magic_bytes(self):
|
|
conn = self.nodes[0].add_p2p_connection(P2PDataStore())
|
|
|
|
- def swap_magic_bytes():
|
|
+ async def swap_magic_bytes():
|
|
conn._on_data = lambda: None # Need to ignore all incoming messages from now, since they come with "invalid" magic bytes
|
|
conn.magic_bytes = b'\x00\x11\x22\x32'
|
|
|
|
# Call .result() to block until the atomic swap is complete, otherwise
|
|
# we might run into races later on
|
|
- asyncio.run_coroutine_threadsafe(asyncio.coroutine(swap_magic_bytes)(), NetworkThread.network_event_loop).result()
|
|
+ asyncio.run_coroutine_threadsafe(swap_magic_bytes(), NetworkThread.network_event_loop).result()
|
|
|
|
with self.nodes[0].assert_debug_log(['PROCESSMESSAGE: INVALID MESSAGESTART ping']):
|
|
conn.send_message(messages.msg_ping(nonce=0xff))
|