mirror of
https://git.in.rschanz.org/ryan77627/guix.git
synced 2024-11-08 07:56:16 -05:00
05e1534ee8
* gnu/packages/kodi.scm (kodi): Update to 18.2. * gnu/packages/patches/kodi-set-libcurl-ssl-parameters.patch: Adjust for upstream changes.
17 lines
797 B
Diff
17 lines
797 B
Diff
Kodi doesn't set the CAPATH and CAINFO parameters for libcurl. To make HTTPS
|
|
connections work we can set them based on SSL_CERT_DIR and SSL_CERT_FILE.
|
|
|
|
--- a/xbmc/filesystem/CurlFile.cpp
|
|
+++ b/xbmc/filesystem/CurlFile.cpp
|
|
@@ -626,5 +626,9 @@
|
|
if (!m_cipherlist.empty())
|
|
g_curlInterface.easy_setopt(h, CURLOPT_SSL_CIPHER_LIST, m_cipherlist.c_str());
|
|
|
|
+ // Load certificate data from environment paths
|
|
+ g_curlInterface.easy_setopt(m_state->m_easyHandle, CURLOPT_CAPATH, getenv("SSL_CERT_DIR"));
|
|
+ g_curlInterface.easy_setopt(m_state->m_easyHandle, CURLOPT_CAINFO, getenv("SSL_CERT_FILE"));
|
|
+
|
|
// enable HTTP2 support. default: CURL_HTTP_VERSION_1_1. Curl >= 7.62.0 defaults to CURL_HTTP_VERSION_2TLS
|
|
g_curlInterface.easy_setopt(h, CURLOPT_HTTP_VERSION, CURL_HTTP_VERSION_2_0);
|
|
-
|
|
}
|