mirror of
https://git.in.rschanz.org/ryan77627/guix.git
synced 2024-11-08 07:56:16 -05:00
dc4fae11ab
* gnu/packages/freedesktop.scm (udiskie): Update to 2.0.4. * gnu/packages/patches/udiskie-no-appindicator.patch: Update for 2.0.4.
155 lines
6 KiB
Diff
155 lines
6 KiB
Diff
Remove the support for Unity's appindicator.
|
|
|
|
diff -Naur udiskie-2.0.4/completions/zsh/_udiskie udiskie-2.0.4-new/completions/zsh/_udiskie
|
|
--- udiskie-2.0.4/completions/zsh/_udiskie 2020-01-21 01:12:40.000000000 +0100
|
|
+++ udiskie-2.0.4-new/completions/zsh/_udiskie 2020-01-23 10:15:46.956141667 +0100
|
|
@@ -18,8 +18,6 @@
|
|
'(-a)'{-A,--no-automount}"[disable automounting]"
|
|
'(-N)'{-n,--notify}"[show popup notifications]"
|
|
'(-n)'{-N,--no-notify}"[disable notifications]"
|
|
- '(--no-appindicator)'--appindicator"[use appindicator for status icon]"
|
|
- '(--appindicator)'--no-appindicator"[don't use appindicator]"
|
|
'(-T -s)'{-t,--tray}"[show tray icon]"
|
|
'(-T -t)'{-s,--smart-tray}"[auto hide tray icon]"
|
|
'(-t -s)'{-T,--no-tray}"[disable tray icon]"
|
|
diff -Naur udiskie-2.0.4/doc/udiskie.8.txt udiskie-2.0.4-new/doc/udiskie.8.txt
|
|
--- udiskie-2.0.4/doc/udiskie.8.txt 2020-01-21 01:12:40.000000000 +0100
|
|
+++ udiskie-2.0.4-new/doc/udiskie.8.txt 2020-01-23 10:16:12.636290647 +0100
|
|
@@ -92,12 +92,6 @@
|
|
*--no-terminal*::
|
|
Disable terminal action.
|
|
|
|
-*--appindicator*::
|
|
- Use AppIndicator3 for the status icon. Use this on Ubuntu/Unity if no icon is shown.
|
|
-
|
|
-*--no-appindicator*::
|
|
- Use Gtk.StatusIcon for the status icon (default).
|
|
-
|
|
*--password-cache MINUTES*::
|
|
Cache passwords for LUKS partitions and set the timeout.
|
|
|
|
diff -Naur udiskie-2.0.4/udiskie/appindicator.py udiskie-2.0.4-new/udiskie/appindicator.py
|
|
--- udiskie-2.0.4/udiskie/appindicator.py 2020-01-21 01:12:40.000000000 +0100
|
|
+++ udiskie-2.0.4-new/udiskie/appindicator.py 1970-01-01 01:00:00.000000000 +0100
|
|
@@ -1,61 +0,0 @@
|
|
-"""
|
|
-Status icon using AppIndicator3.
|
|
-"""
|
|
-
|
|
-from gi.repository import Gtk
|
|
-from gi.repository import AppIndicator3
|
|
-
|
|
-from .async_ import Future
|
|
-
|
|
-
|
|
-class AppIndicatorIcon:
|
|
-
|
|
- """
|
|
- Show status icon using AppIndicator as backend. Replaces
|
|
- `udiskie.tray.StatusIcon` on ubuntu/unity.
|
|
- """
|
|
-
|
|
- def __init__(self, menumaker, _icons):
|
|
- self._maker = menumaker
|
|
- self._menu = Gtk.Menu()
|
|
- self._indicator = AppIndicator3.Indicator.new(
|
|
- 'udiskie',
|
|
- _icons.get_icon_name('media'),
|
|
- AppIndicator3.IndicatorCategory.HARDWARE)
|
|
- self._indicator.set_status(AppIndicator3.IndicatorStatus.PASSIVE)
|
|
- self._indicator.set_menu(self._menu)
|
|
- # Get notified before menu is shown, see:
|
|
- # https://bugs.launchpad.net/screenlets/+bug/522152/comments/15
|
|
- dbusmenuserver = self._indicator.get_property('dbus-menu-server')
|
|
- self._dbusmenuitem = dbusmenuserver.get_property('root-node')
|
|
- self._conn = self._dbusmenuitem.connect('about-to-show', self._on_show)
|
|
- self.task = Future()
|
|
- menumaker._quit_action = self.destroy
|
|
- # Populate menu initially, so libdbusmenu does not ignore the
|
|
- # 'about-to-show':
|
|
- self._maker(self._menu)
|
|
-
|
|
- def destroy(self):
|
|
- self.show(False)
|
|
- self._dbusmenuitem.disconnect(self._conn)
|
|
- self.task.set_result(True)
|
|
-
|
|
- @property
|
|
- def visible(self):
|
|
- status = self._indicator.get_status()
|
|
- return status == AppIndicator3.IndicatorStatus.ACTIVE
|
|
-
|
|
- def show(self, show=True):
|
|
- if show == self.visible:
|
|
- return
|
|
- status = (AppIndicator3.IndicatorStatus.ACTIVE if show else
|
|
- AppIndicator3.IndicatorStatus.PASSIVE)
|
|
- self._indicator.set_status(status)
|
|
-
|
|
- def _on_show(self, menu):
|
|
- # clear menu:
|
|
- for item in self._menu.get_children():
|
|
- self._menu.remove(item)
|
|
- # repopulate:
|
|
- self._maker(self._menu)
|
|
- self._menu.show_all()
|
|
diff -Naur udiskie-2.0.4/udiskie/cli.py udiskie-2.0.4-new/udiskie/cli.py
|
|
--- udiskie-2.0.4/udiskie/cli.py 2020-01-21 01:12:40.000000000 +0100
|
|
+++ udiskie-2.0.4-new/udiskie/cli.py 2020-01-23 10:17:13.064810617 +0100
|
|
@@ -287,9 +287,6 @@
|
|
-T, --no-tray Disable tray icon
|
|
-m MENU, --menu MENU Tray menu [flat/nested]
|
|
|
|
- --appindicator Use appindicator for status icon
|
|
- --no-appindicator Don't use appindicator
|
|
-
|
|
--password-cache MINUTES Set password cache timeout
|
|
--no-password-cache Disable password cache
|
|
|
|
@@ -312,7 +309,6 @@
|
|
'notify': True,
|
|
'tray': False,
|
|
'menu': 'flat',
|
|
- 'appindicator': False,
|
|
'file_manager': 'xdg-open',
|
|
'terminal': '',
|
|
'password_prompt': 'builtin:gui',
|
|
@@ -328,7 +324,6 @@
|
|
'--no-tray': False,
|
|
'--smart-tray': 'auto'}),
|
|
'menu': Value('--menu'),
|
|
- 'appindicator': Switch('appindicator'),
|
|
'file_manager': OptionalValue('--file-manager'),
|
|
'password_prompt': OptionalValue('--password-prompt'),
|
|
'password_cache': OptionalValue('--password-cache'),
|
|
@@ -459,11 +454,7 @@
|
|
|
|
menu_maker = udiskie.tray.UdiskieMenu(self, icons, actions, flat,
|
|
config.quickmenu_actions)
|
|
- if options['appindicator']:
|
|
- import udiskie.appindicator
|
|
- TrayIcon = udiskie.appindicator.AppIndicatorIcon
|
|
- else:
|
|
- TrayIcon = udiskie.tray.TrayIcon
|
|
+ TrayIcon = udiskie.tray.TrayIcon
|
|
trayicon = TrayIcon(menu_maker, icons)
|
|
return udiskie.tray.UdiskieStatusIcon(trayicon, menu_maker, smart)
|
|
|
|
diff -Naur udiskie-2.0.4/udiskie.egg-info/SOURCES.txt udiskie-2.0.4-new/udiskie.egg-info/SOURCES.txt
|
|
--- udiskie-2.0.4/udiskie.egg-info/SOURCES.txt 2020-01-21 01:12:41.000000000 +0100
|
|
+++ udiskie-2.0.4-new/udiskie.egg-info/SOURCES.txt 2020-01-23 10:17:50.657205798 +0100
|
|
@@ -25,7 +25,6 @@
|
|
test/test_cache.py
|
|
test/test_match.py
|
|
udiskie/__init__.py
|
|
-udiskie/appindicator.py
|
|
udiskie/async_.py
|
|
udiskie/automount.py
|
|
udiskie/cache.py
|
|
@@ -47,4 +46,4 @@
|
|
udiskie.egg-info/entry_points.txt
|
|
udiskie.egg-info/requires.txt
|
|
udiskie.egg-info/top_level.txt
|
|
-udiskie.egg-info/zip-safe
|
|
\ Pas de fin de ligne à la fin du fichier
|
|
+udiskie.egg-info/zip-safe
|