mirror of
https://git.in.rschanz.org/ryan77627/guix.git
synced 2024-11-15 03:15:09 -05:00
4bdd41bb83
* gnu/packages/patches/handbrake-opt-in-nvenc.patch: New file. * gnu/local.mk (dist_patch_DATA): Add it. * gnu/packages/video.scm (handbrake)[source]: Upgrade to 1.2.0. Use patch. [native-inputs]: Add cmake. [inputs]: Add speex. [arguments]: Disable runtime update checks via #:configure-flags.
14 lines
770 B
Diff
14 lines
770 B
Diff
Require opt-in for NVEnc support. Otherwise the default is true with no way
|
|
to disable it.
|
|
|
|
--- HandBrake-1.2.0/make/configure.py.orig 1969-12-31 18:00:00.000000000 -0600
|
|
+++ HandBrake-1.2.0/make/configure.py 2019-01-22 23:22:46.186959060 -0600
|
|
@@ -1320,7 +1320,7 @@
|
|
grp.add_option( '--disable-ffmpeg-aac', dest="enable_ffmpeg_aac", action='store_false' )
|
|
|
|
h = IfHost( 'enable Nvidia NVEnc video encoder', '*-*-*', none=optparse.SUPPRESS_HELP ).value
|
|
- grp.add_option( '--enable-nvenc', dest="enable_nvenc", default=not (host.match( '*-*-darwin*' ) or host.match( '*-*-freebsd*' )), action='store_true', help=h )
|
|
+ grp.add_option( '--enable-nvenc', dest="enable_nvenc", default=False, action='store_true', help=h )
|
|
|
|
|
|
cli.add_option_group( grp )
|