mirror of
https://git.in.rschanz.org/ryan77627/guix.git
synced 2024-11-17 20:27:36 -05:00
c94367eaaf
* gnu/packages/patches/sbcl-geco-fix-organism-class.patch: New file. * gnu/local.mk (dist_patch_DATA): Add it. * gnu/packages/lisp-xyz.scm (sbcl-geco)[source]: Use it.
13 lines
402 B
Diff
13 lines
402 B
Diff
Fix the ORGANISM class so that SBCL >= 2.0.9 can compile it without error.
|
|
|
|
--- a/classes.lisp 2020-10-28 12:11:10.725659464 +0100
|
|
+++ b/classes.lisp 2020-10-31 17:34:36.822752447 +0100
|
|
@@ -148,7 +148,7 @@
|
|
:accessor score
|
|
:initarg :score
|
|
:initform 'nil
|
|
- :type number)
|
|
+ :type (or number null))
|
|
(NORMALIZED-SCORE
|
|
:accessor normalized-score
|
|
:initarg :normalized-score
|