mirror of
https://git.in.rschanz.org/ryan77627/guix.git
synced 2024-11-07 23:46:13 -05:00
ee7a7c9014
* gnu/packages/patches/genimage-signedness.patch: New file. * gnu/packages/genimage.scm (genimage)[source]: Add patch. * gnu/local.mk (dist_patch_DATA): Register patch.
24 lines
1 KiB
Diff
24 lines
1 KiB
Diff
commit 6574665f9d6c0757e8f55ccb465afbcaa90bf019
|
||
Author: Timotej Lazar <timotej.lazar@araneo.si>
|
||
Date: Wed Aug 19 19:36:02 2020 +0200
|
||
|
||
test: normalize flags reported by dumpe2fs
|
||
|
||
Filesystem flags depend on the system – usually signed_directory_hash,
|
||
but unsigned_directory_hash at least on arm64.
|
||
|
||
Signed-off-by: Timotej Lazar <timotej.lazar@araneo.si>
|
||
|
||
diff --git a/test/basic-images.test b/test/basic-images.test
|
||
index f6685e1..cb104c3 100755
|
||
--- a/test/basic-images.test
|
||
+++ b/test/basic-images.test
|
||
@@ -158,6 +158,8 @@ check_ext() {
|
||
# format change
|
||
csum2="Group 0: (Blocks 1-4095) \\[ITABLE_ZEROED\\]\| Checksum .*, unused inodes 205"
|
||
dumpe2fs "${1}" | grep -v "^\($uuid\|$seed\|$csum1\|$csum2\)" > "dump" &&
|
||
+ # some architectures (including arm64) use unsigned char
|
||
+ sed -i 's/un\(signed_directory_hash\)/\1/' "dump" &&
|
||
# fixup for ext3 journal size with old tune2fs
|
||
sed -i 's/^\(Journal size: \)1029k$/\11024k/' "dump" &&
|
||
# output format changed with some version
|