mirror of
https://git.in.rschanz.org/ryan77627/guix.git
synced 2024-11-07 23:46:13 -05:00
633e8aab69
* gnu/packages/ldc.scm (ldc): Update to 1.10.0. [native-inputs]: Switch to LLVM and CLANG. (ldc-bootstrap)[synopsis, description]: Tweak. * gnu/packages/patches/ldc-disable-phobos-tests.patch: New file. * gnu/packages/patches/ldc-1.7.0-disable-phobos-tests.patch: Remove. * gnu/local.mk (dist_patch_DATA): Adjust accordingly. Signed-off-by: Ludovic Courtès <ludo@gnu.org>
22 lines
530 B
Diff
22 lines
530 B
Diff
diff --git a/std/socket.d b/std/socket.d
|
|
index 111cd17..6d23da9 100644
|
|
--- a/std/socket.d
|
|
+++ b/std/socket.d
|
|
@@ -448,7 +448,7 @@ class Protocol
|
|
// Skip this test on Android because getprotobyname/number are
|
|
// unimplemented in bionic.
|
|
version(CRuntime_Bionic) {} else
|
|
-@safe unittest
|
|
+@safe version(hasNetwork) unittest
|
|
{
|
|
// import std.stdio : writefln;
|
|
softUnittest({
|
|
@@ -770,7 +770,7 @@ class InternetHost
|
|
}
|
|
|
|
///
|
|
-@safe unittest
|
|
+@safe version(hasNetwork) unittest
|
|
{
|
|
InternetHost ih = new InternetHost;
|
|
|