mirror of
https://git.in.rschanz.org/ryan77627/guix.git
synced 2024-11-07 23:46:13 -05:00
4b96149d8b
* gnu/packages/patches/libtiff-CVE-2016-10092.patch, gnu/packages/patches/libtiff-CVE-2016-10093.patch, gnu/packages/patches/libtiff-CVE-2016-10094.patch, gnu/packages/patches/libtiff-assertion-failure.patch, gnu/packages/patches/libtiff-divide-by-zero-ojpeg.patch, gnu/packages/patches/libtiff-divide-by-zero-tiffcp.patch, gnu/packages/patches/libtiff-divide-by-zero-tiffcrop.patch, gnu/packages/patches/libtiff-divide-by-zero.patch, gnu/packages/patches/libtiff-heap-overflow-pixarlog-luv.patch, gnu/packages/patches/libtiff-heap-overflow-tif-dirread.patch, gnu/packages/patches/libtiff-heap-overflow-tiffcp.patch, gnu/packages/patches/libtiff-heap-overflow-tiffcrop.patch, gnu/packages/patches/libtiff-invalid-read.patch, gnu/packages/patches/libtiff-null-dereference.patch, gnu/packages/patches/libtiff-tiffcp-underflow.patch: New files. * gnu/local.mk (dist_patch_DATA): Add them. * gnu/packages/image.scm (libtiff)[replacement]: New field. (libtiff/fixed): New variable.
42 lines
1.4 KiB
Diff
42 lines
1.4 KiB
Diff
Fix NULL pointer dereference in TIFFReadRawData():
|
|
|
|
http://bugzilla.maptools.org/show_bug.cgi?id=2594
|
|
|
|
|
|
2016-12-03 Even Rouault <even.rouault at spatialys.com>
|
|
|
|
* tools/tiffinfo.c: fix null pointer dereference in -r mode when
|
|
* the
|
|
image has
|
|
no StripByteCount tag.
|
|
Reported by Agostino Sarubbo.
|
|
Fixes http://bugzilla.maptools.org/show_bug.cgi?id=2594
|
|
|
|
/cvs/maptools/cvsroot/libtiff/ChangeLog,v <-- ChangeLog
|
|
new revision: 1.1182; previous revision: 1.1181
|
|
/cvs/maptools/cvsroot/libtiff/tools/tiffinfo.c,v <-- tools/tiffinfo.c
|
|
new revision: 1.26; previous revision: 1.25
|
|
|
|
Index: libtiff/tools/tiffinfo.c
|
|
===================================================================
|
|
RCS file: /cvs/maptools/cvsroot/libtiff/tools/tiffinfo.c,v
|
|
retrieving revision 1.25
|
|
retrieving revision 1.26
|
|
diff -u -r1.25 -r1.26
|
|
--- libtiff/tools/tiffinfo.c 12 Nov 2016 20:06:05 -0000 1.25
|
|
+++ libtiff/tools/tiffinfo.c 3 Dec 2016 14:18:49 -0000 1.26
|
|
@@ -1,4 +1,4 @@
|
|
-/* $Id: tiffinfo.c,v 1.25 2016-11-12 20:06:05 bfriesen Exp $ */
|
|
+/* $Id: tiffinfo.c,v 1.26 2016-12-03 14:18:49 erouault Exp $ */
|
|
|
|
/*
|
|
* Copyright (c) 1988-1997 Sam Leffler
|
|
@@ -417,7 +417,7 @@
|
|
uint64* stripbc=NULL;
|
|
|
|
TIFFGetField(tif, TIFFTAG_STRIPBYTECOUNTS, &stripbc);
|
|
- if (nstrips > 0) {
|
|
+ if (stripbc != NULL && nstrips > 0) {
|
|
uint32 bufsize = (uint32) stripbc[0];
|
|
tdata_t buf = _TIFFmalloc(bufsize);
|
|
tstrip_t s;
|