mirror of
https://git.in.rschanz.org/ryan77627/guix.git
synced 2024-12-29 07:42:23 -05:00
1717c8a233
Fixes <https://issues.guix.gnu.org/64605> and similar reports. * gnu/packages/patches/qtdeclarative-5-disable-qmlcache.patch: New patch. * gnu/packages/patches/qtdeclarative-disable-qmlcache.patch: Likewise. * gnu/local.mk (dist_patch_DATA): Register them. * gnu/packages/qt.scm (qtdeclarative-5, qtdeclarative): Apply them. Reported-by: Distopico Vegan <distopico@riseup.net>
16 lines
681 B
Diff
16 lines
681 B
Diff
Retrieved from
|
|
https://raw.githubusercontent.com/NixOS/nixpkgs/master/pkgs/development/libraries/qt-6/patches/qtdeclarative-default-disable-qmlcache.patch
|
|
|
|
diff --git a/src/qml/jsruntime/qv4engine.cpp b/src/qml/jsruntime/qv4engine.cpp
|
|
index 852cde9e..165f1b57 100644
|
|
--- a/src/qml/jsruntime/qv4engine.cpp
|
|
+++ b/src/qml/jsruntime/qv4engine.cpp
|
|
@@ -2093,7 +2093,7 @@ void ExecutionEngine::registerModule(const QString &_name, const QJSValue &modul
|
|
|
|
bool ExecutionEngine::diskCacheEnabled() const
|
|
{
|
|
- return (!disableDiskCache() && !debugger()) || forceDiskCache();
|
|
+ return forceDiskCache();
|
|
}
|
|
|
|
void ExecutionEngine::callInContext(QV4::Function *function, QObject *self,
|