mirror of
https://git.in.rschanz.org/ryan77627/guix.git
synced 2025-01-09 20:59:31 -05:00
5aeb96103f
* gnu/packages/compression.scm (zlib): Update to 1.2.12. [source](patches): New field. [arguments]: Set CC variable. * gnu/packages/commencement.scm (zlib-final)[source]: New field. * gnu/packages/patches/zlib-cc.patch, gnu/packages/patches/zlib-correct-crc32-inputs.patch: New files. * gnu/local.mk (dist_patch_DATA): Adjust accordingly.
21 lines
477 B
Diff
21 lines
477 B
Diff
Fix configure issue that discarded provided CC definition.
|
|
|
|
Taken from upstream:
|
|
|
|
https://github.com/madler/zlib/commit/05796d3d8d5546cf1b4dfe2cd72ab746afae505d
|
|
|
|
diff --git a/configure b/configure
|
|
index 52ff4a04e..3fa3e8618 100755
|
|
--- a/configure
|
|
+++ b/configure
|
|
@@ -174,7 +174,10 @@ if test -z "$CC"; then
|
|
else
|
|
cc=${CROSS_PREFIX}cc
|
|
fi
|
|
+else
|
|
+ cc=${CC}
|
|
fi
|
|
+
|
|
cflags=${CFLAGS-"-O3"}
|
|
# to force the asm version use: CFLAGS="-O3 -DASMV" ./configure
|
|
case "$cc" in
|