guix/gnu/packages/patches/scilab-tbx_build_help.patch
Nicolas Graves 04d4e772e5
gnu: scilab: Improve package management robustness in scilab-cli.
* gnu/packages/maths.scm (scilab)[source]<origin>: Improve
  package management robustness in scilab-cli by allowing
  tbx_build_help to log the scilab mode incompatibility error and not
  process the rest of the function instead of failing with it.
* gnu/packages/patches/scilab-tbx_build_help.patch :
  Add patch.
* gnu/local.mk(dist_patch_DATA): Add
  gnu/packages/patches/scilab-tbx_build_help.patch.

Change-Id: I8ee94afb4aba906cbc8c7ca67f4c89aa0cf55ae6
Signed-off-by: Ludovic Courtès <ludo@gnu.org>
2024-05-01 23:45:34 +02:00

38 lines
1.4 KiB
Diff

From c59d78c5a5c8c187450f157cf7f8480455e8e6a2 Mon Sep 17 00:00:00 2001
From: Nicolas Graves <ngraves@ngraves.fr>
Date: Wed, 3 Apr 2024 03:32:23 +0200
Subject: [PATCH] scilab: tbx_build_help: Allow for some flexibility under
-nwni.
upstream reference: https://gitlab.com/scilab/scilab/-/merge_requests/818
---
.../modules_manager/macros/tbx_build_help.sci | 12 ++++++------
1 file changed, 6 insertions(+), 6 deletions(-)
diff --git a/scilab/modules/modules_manager/macros/tbx_build_help.sci b/scilab/modules/modules_manager/macros/tbx_build_help.sci
index 7862e33a868..5593ee3dc04 100644
--- a/scilab/modules/modules_manager/macros/tbx_build_help.sci
+++ b/scilab/modules/modules_manager/macros/tbx_build_help.sci
@@ -58,12 +58,12 @@ function tbx_build_help(moduletitle, path)
// Check scilab mode
if and(getscilabmode() <> ["STD" "NW"]) then
- error(msprintf(gettext("%s: documentation cannot be built in this scilab mode: %s.\n"),"tbx_build_help",getscilabmode()));
+ msprintf(gettext("%s: documentation cannot be built in this scilab mode: %s.\n"),"tbx_build_help",getscilabmode());
+ else
+ directory_language = basename(path);
+ default_language = "en_US"
+
+ xmltojar(path, moduletitle, directory_language, default_language);
end
- directory_language = basename(path);
- default_language = "en_US"
-
- xmltojar(path, moduletitle, directory_language, default_language);
-
endfunction
--
2.41.0