mirror of
https://git.in.rschanz.org/ryan77627/guix.git
synced 2024-11-12 09:56:14 -05:00
5981e99f0a
* gnu/packages/patches/hurd-fix-rumpdisk-build.patch, gnu/packages/patches/hurd-rumpdisk-no-hd.patch: New files. * gnu/local.mk (dist_patch_DATA): Add them. * gnu/packages/hurd.scm (hurd): Use them. (hurd)[inputs]: Replace util-linux with util-linux:static, add parted, rumpkernel. [arguments]: Rename `prepare-dde' phase to 'prepare-addons'. Add "rumpdisk" directory. Add --enable-static-progs=... option to #:configure-flags, and remove --without-parted. Signed-off-by: Josselin Poiret <dev@jpoiret.xyz>
26 lines
930 B
Diff
26 lines
930 B
Diff
This avoids rumpdisk crash when booting without "noide".
|
|
|
|
Upstream status: Taken from Debian Salsa package git
|
|
|
|
https://salsa.debian.org/hurd-team/hurd/-/blob/f40ff84260b5a98bea949013415a1c92c127a43e/debian/patches/rumpdisk-no-hd
|
|
|
|
Index: hurd-debian/rumpdisk/block-rump.c
|
|
===================================================================
|
|
--- hurd-debian.orig/rumpdisk/block-rump.c
|
|
+++ hurd-debian/rumpdisk/block-rump.c
|
|
@@ -143,7 +143,6 @@ rumpdisk_device_init (void)
|
|
{
|
|
device_t device;
|
|
|
|
-#if 0
|
|
if (! device_open (device_master, D_READ, "hd0", &device)
|
|
|| ! device_open (device_master, D_READ, "hd1", &device)
|
|
|| ! device_open (device_master, D_READ, "hd3", &device)
|
|
@@ -154,7 +153,6 @@ rumpdisk_device_init (void)
|
|
disabled = 1;
|
|
return;
|
|
}
|
|
-#endif
|
|
|
|
if (! device_open (device_master, D_READ, "sd0", &device)
|
|
|| ! device_open (device_master, D_READ, "sd1", &device)
|