mirror of
https://git.in.rschanz.org/ryan77627/guix.git
synced 2024-11-12 09:56:14 -05:00
49a320aaa6
Script-aided bulk change.
16 lines
513 B
Diff
16 lines
513 B
Diff
This patch is required for xmonad to make use of shared libraries.
|
|
Without it, xmonad will not work since we do not (by default) use
|
|
statically linked Haskell libraries.
|
|
|
|
index 46a0939..5ad4f8f 100644
|
|
--- a/src/XMonad/Core.hs
|
|
+++ b/src/XMonad/Core.hs
|
|
@@ -664,6 +664,8 @@ compile dirs method =
|
|
where
|
|
ghcArgs = [ "--make"
|
|
, "xmonad.hs"
|
|
+ , "-dynamic"
|
|
+ , "-fPIC"
|
|
, "-i" -- only look in @lib@
|
|
, "-ilib"
|
|
, "-fforce-recomp"
|