mirror of
https://git.in.rschanz.org/ryan77627/guix.git
synced 2024-11-08 07:56:16 -05:00
a8e149434e
Patches should fix all CVEs reported by `guix lint`: CVE-2015-7747; CVE-2017-6827, CVE-2017-6828, CVE-2017-6829, CVE-2017-6830, CVE-2017-6831, CVE-2017-6832, CVE-2017-6833, CVE-2017-6834, CVE-2017-6835, CVE-2017-6836, CVE-2017-6837, CVE-2017-6838, CVE-2017-6839; CVE-2018-13440; CVE-2018-17095 Since the patches do not reference to CVEs, it's a bit hard to tell which patch actually closes which CVE. Debian reports all these to be closed by the patches below and NixPkgs provides references. * gnu/packages/audio.scm (audiofile): New variable. * gnu/packages/patches/audiofile-fix-datatypes-in-tests.patch, gnu/packages/patches/audiofile-fix-sign-conversion.patch, gnu/packages/patches/audiofile-CVE-2015-7747.patch, gnu/packages/patches/audiofile-CVE-2018-13440.patch, gnu/packages/patches/audiofile-CVE-2018-17095.patch, gnu/packages/patches/audiofile-Check-the-number-of-coefficients.patch, gnu/packages/patches/audiofile-Fail-on-error-in-parseFormat.patch, gnu/packages/patches/audiofile-Fix-index-overflow-in-IMA.cpp.patch, gnu/packages/patches/audiofile-Fix-multiply-overflow-sfconvert.patch, gnu/packages/patches/audiofile-Fix-overflow-in-MSADPCM-decodeSam.patch, gnu/packages/patches/audiofile-division-by-zero-BlockCodec-runPull.patch, gnu/packages/patches/audiofile-hurd.patch, gnu/packages/patches/audiofile-signature-of-multiplyCheckOverflow.patch: New files. * gnu/local.mk: Add them.
35 lines
1.3 KiB
Diff
35 lines
1.3 KiB
Diff
From: Antonio Larrosa <larrosa@kde.org>
|
|
Date: Fri, 10 Mar 2017 15:40:02 +0100
|
|
Subject: Fix signature of multiplyCheckOverflow. It returns a bool, not an int
|
|
|
|
---
|
|
libaudiofile/modules/MSADPCM.cpp | 2 +-
|
|
sfcommands/sfconvert.c | 2 +-
|
|
2 files changed, 2 insertions(+), 2 deletions(-)
|
|
|
|
diff --git a/libaudiofile/modules/MSADPCM.cpp b/libaudiofile/modules/MSADPCM.cpp
|
|
index ef9c38c..d8c9553 100644
|
|
--- a/libaudiofile/modules/MSADPCM.cpp
|
|
+++ b/libaudiofile/modules/MSADPCM.cpp
|
|
@@ -116,7 +116,7 @@ int firstBitSet(int x)
|
|
#define __has_builtin(x) 0
|
|
#endif
|
|
|
|
-int multiplyCheckOverflow(int a, int b, int *result)
|
|
+bool multiplyCheckOverflow(int a, int b, int *result)
|
|
{
|
|
#if (defined __GNUC__ && __GNUC__ >= 5) || ( __clang__ && __has_builtin(__builtin_mul_overflow))
|
|
return __builtin_mul_overflow(a, b, result);
|
|
diff --git a/sfcommands/sfconvert.c b/sfcommands/sfconvert.c
|
|
index 970a3e4..367f7a5 100644
|
|
--- a/sfcommands/sfconvert.c
|
|
+++ b/sfcommands/sfconvert.c
|
|
@@ -60,7 +60,7 @@ int firstBitSet(int x)
|
|
#define __has_builtin(x) 0
|
|
#endif
|
|
|
|
-int multiplyCheckOverflow(int a, int b, int *result)
|
|
+bool multiplyCheckOverflow(int a, int b, int *result)
|
|
{
|
|
#if (defined __GNUC__ && __GNUC__ >= 5) || ( __clang__ && __has_builtin(__builtin_mul_overflow))
|
|
return __builtin_mul_overflow(a, b, result);
|