mirror of
https://git.in.rschanz.org/ryan77627/guix.git
synced 2024-11-15 11:25:22 -05:00
fd22921490
This commit backports an upstream repair for a bug exposed by Guix's change in Racket 8.2 to make the `racket` package a layered/tethered installation that chains to the `racket-minimal` package. When using a layered/tethered installation, the `setup/variant` library would fail to recognize the default Racet variant (CS, 3M, or CGC), leading to confusing failures from `raco exe`, `create-embedding-executable`, and other clients. For further details, see <https://issues.guix.gnu.org/50118> and <https://github.com/racket/racket/issues/3969>. * gnu/packages/patches/racket-minimal-backport-1629887.patch: New file. * gnu/local.mk (dist_patch_DATA): Add it. * gnu/packages/racket.scm (racket-minimal)[source]: Use it. Signed-off-by: Ludovic Courtès <ludo@gnu.org>
28 lines
980 B
Diff
28 lines
980 B
Diff
From fb1a6ab205fd63a46669a463931af473e2ac0c87 Mon Sep 17 00:00:00 2001
|
|
From: Matthew Flatt <mflatt@racket-lang.org>
|
|
Date: Sat, 21 Aug 2021 15:29:59 -0600
|
|
Subject: [PATCH] setup/variant: recognize starter executables
|
|
|
|
Related to #3969
|
|
|
|
(cherry picked from commit 1629887071fe3cc8fe8af0a7aa0d3912509cb058)
|
|
---
|
|
racket/collects/setup/variant.rkt | 2 +-
|
|
1 file changed, 1 insertion(+), 1 deletion(-)
|
|
|
|
diff --git a/racket/collects/setup/variant.rkt b/racket/collects/setup/variant.rkt
|
|
index 81da6f5701..b23131e481 100644
|
|
--- a/racket/collects/setup/variant.rkt
|
|
+++ b/racket/collects/setup/variant.rkt
|
|
@@ -25,7 +25,7 @@
|
|
(and (file-exists? f)
|
|
(with-input-from-file f
|
|
(lambda ()
|
|
- (define m (regexp-match #rx#"bINARy tYPe:..(.)"
|
|
+ (define m (regexp-match #rx#"bINARy tYPe:e?..(.)"
|
|
(current-input-port)))
|
|
(cond
|
|
[(not m) '3m]
|
|
--
|
|
2.30.2
|
|
|