mirror of
https://git.in.rschanz.org/ryan77627/guix.git
synced 2024-12-29 07:42:23 -05:00
c463d7ac91
* gnu/packages/java.scm (openjdk10)[source](patches): Add two patches. [source](snippet): While here, simplify. * gnu/packages/patches/openjdk-10-hotspot-pointer-comparison.patch, gnu/packages/patches/openjdk-10-hotspot-stack-size.patch: New files. * gnu/local.mk (dist_patch_DATA): Adjust accordingly.
15 lines
532 B
Diff
15 lines
532 B
Diff
Avoid ordered comparison of pointer with integer to prevent compile error
|
|
with GCC 11.
|
|
|
|
diff --git a/src/hotspot/os/linux/os_linux.cpp b/src/hotspot/os/linux/os_linux.cpp
|
|
--- a/src/hotspot/os/linux/os_linux.cpp
|
|
+++ b/src/hotspot/os/linux/os_linux.cpp
|
|
@@ -2155,7 +2155,7 @@ void os::Linux::print_container_info(outputStream* st) {
|
|
}
|
|
|
|
p = OSContainer::cpu_cpuset_memory_nodes();
|
|
- if (p < 0)
|
|
+ if (p == NULL)
|
|
st->print("cpu_memory_nodes() failed\n");
|
|
else {
|
|
st->print("cpu_memory_nodes: %s\n", p);
|