mirror of
https://git.in.rschanz.org/ryan77627/guix.git
synced 2024-11-07 23:46:13 -05:00
0957f20cb7
After the update to libportal-0.5 in 294476022f
eog fails with:
../eog-40.3/src/eog-util.c:48:10: fatal error: libportal/portal-gtk3.h: No such file or directory
This was already fixed upstream and this commits extracts the patch.
* gnu/packages/patches/eog-update-libportal-usage.patch: New file.
* gnu/local.mk (dist_patch_DATA): Register it.
* gnu/packages/gnome.scm(eog)[origin]: Add new patch.
Signed-off-by: Guillaume Le Vaillant <glv@posteo.net>
40 lines
1.6 KiB
Diff
40 lines
1.6 KiB
Diff
Fix eog to work with libportal-0.5
|
|
|
|
This patch is extracted from upstream, see here
|
|
https://gitlab.gnome.org/GNOME/eog/-/commit/a06e6325907e136678b0bbe7058c25d688034afd
|
|
|
|
diff --git a/meson.build b/meson.build
|
|
index 9a32e4bb..9d49aa45 100644
|
|
--- a/meson.build
|
|
+++ b/meson.build
|
|
@@ -165,10 +165,14 @@ config_h.set('HAVE_EXEMPI', enable_xmp)
|
|
# xdg-desktop-portal support with libportal (optional)
|
|
enable_libportal = get_option('libportal')
|
|
if enable_libportal
|
|
- libportal_dep = dependency('libportal', version: '>= 0.3', required: false)
|
|
+ libportal_dep = dependency('libportal', version: '>= 0.5', required: false)
|
|
assert(libportal_dep.found() and cc.has_header('libportal/portal.h', dependencies: libportal_dep),
|
|
'xdg-desktop-portal support requested but library not found. Please use -Dlibportal=false')
|
|
|
|
- common_deps += libportal_dep
|
|
+ libportal_gtk3_dep = dependency('libportal-gtk3', version: '>= 0.5', required: false)
|
|
+ assert(libportal_gtk3_dep.found() and cc.has_header('libportal-gtk3/portal-gtk3.h', dependencies: libportal_gtk3_dep),
|
|
+ 'xdg-desktop-portal support requested but library not found. Please use -Dlibportal=false')
|
|
+
|
|
+ common_deps += [libportal_dep, libportal_gtk3_dep]
|
|
endif
|
|
config_h.set('HAVE_LIBPORTAL', enable_libportal)
|
|
|
|
diff --git a/src/eog-util.c b/src/eog-util.c
|
|
index 90b9768e..56d23472 100644
|
|
--- a/src/eog-util.c
|
|
+++ b/src/eog-util.c
|
|
@@ -45,7 +45,7 @@
|
|
#include <glib/gi18n.h>
|
|
#ifdef HAVE_LIBPORTAL
|
|
#include <libportal/portal.h>
|
|
-#include <libportal/portal-gtk3.h>
|
|
+#include <libportal-gtk3/portal-gtk3.h>
|
|
#endif
|
|
|
|
void
|