mirror of
https://git.in.rschanz.org/ryan77627/guix.git
synced 2024-11-07 23:46:13 -05:00
a9bc8a25eb
* gnu/packages/maths.scm (fxdiv): New variable. * gnu/packages/patches/fxdiv-system-libraries.patch: New file. * gnu/local.mk (dist_patch_DATA): Add it.
44 lines
1.9 KiB
Diff
44 lines
1.9 KiB
Diff
This patch allows the build process to use the provided dependencies instead
|
|
of adding their source as CMake sub-directories (in which case "make install"
|
|
would install googletest's and googlebenchmark's libraries and headers).
|
|
|
|
diff --git a/CMakeLists.txt b/CMakeLists.txt
|
|
index bcae6b5..ff6710d 100644
|
|
--- a/CMakeLists.txt
|
|
+++ b/CMakeLists.txt
|
|
@@ -21,7 +21,7 @@ IF(FXDIV_BUILD_TESTS)
|
|
ENDIF()
|
|
|
|
# ---[ Download deps
|
|
-IF(FXDIV_BUILD_TESTS AND NOT DEFINED GOOGLETEST_SOURCE_DIR)
|
|
+IF(FALSE)
|
|
MESSAGE(STATUS "Downloading Google Test to ${CMAKE_BINARY_DIR}/googletest-source (define GOOGLETEST_SOURCE_DIR to avoid it)")
|
|
CONFIGURE_FILE(cmake/DownloadGoogleTest.cmake "${CMAKE_BINARY_DIR}/googletest-download/CMakeLists.txt")
|
|
EXECUTE_PROCESS(COMMAND "${CMAKE_COMMAND}" -G "${CMAKE_GENERATOR}" .
|
|
@@ -31,7 +31,7 @@ IF(FXDIV_BUILD_TESTS AND NOT DEFINED GOOGLETEST_SOURCE_DIR)
|
|
SET(GOOGLETEST_SOURCE_DIR "${CMAKE_BINARY_DIR}/googletest-source" CACHE STRING "Google Test source directory")
|
|
ENDIF()
|
|
|
|
-IF(FXDIV_BUILD_BENCHMARKS AND NOT DEFINED GOOGLEBENCHMARK_SOURCE_DIR)
|
|
+IF(FALSE)
|
|
MESSAGE(STATUS "Downloading Google Benchmark to ${CMAKE_BINARY_DIR}/googlebenchmark-source (define GOOGLEBENCHMARK_SOURCE_DIR to avoid it)")
|
|
CONFIGURE_FILE(cmake/DownloadGoogleBenchmark.cmake "${CMAKE_BINARY_DIR}/googlebenchmark-download/CMakeLists.txt")
|
|
EXECUTE_PROCESS(COMMAND "${CMAKE_COMMAND}" -G "${CMAKE_GENERATOR}" .
|
|
@@ -54,7 +54,7 @@ INSTALL(FILES include/fxdiv.h DESTINATION ${CMAKE_INSTALL_INCLUDEDIR})
|
|
|
|
IF(FXDIV_BUILD_TESTS)
|
|
# ---[ Build google test
|
|
- IF(NOT TARGET gtest)
|
|
+ IF(FALSE)
|
|
SET(gtest_force_shared_crt ON CACHE BOOL "" FORCE)
|
|
ADD_SUBDIRECTORY(
|
|
"${GOOGLETEST_SOURCE_DIR}"
|
|
@@ -78,7 +78,7 @@ ENDIF()
|
|
|
|
IF(FXDIV_BUILD_BENCHMARKS)
|
|
# ---[ Build google benchmark
|
|
- IF(NOT TARGET benchmark)
|
|
+ IF(FALSE)
|
|
SET(BENCHMARK_ENABLE_TESTING OFF CACHE BOOL "" FORCE)
|
|
ADD_SUBDIRECTORY(
|
|
"${GOOGLEBENCHMARK_SOURCE_DIR}"
|