mirror of
https://git.in.rschanz.org/ryan77627/guix.git
synced 2024-11-07 07:26:13 -05:00
5d53eec337
* gnu/packages/ebook.scm (calibre): Update to 5.14.0. [source]: Adjust the snippet to preserve some files used by the HTML reader. [native-inputs]: Add python-pyqt-builder. Replace python2-flake8 with python-flake8. [inputs]: Remove chmlib, js-mathjax, python-chardet, and python-sip. Add python-cchardet, python-speechd, python-zeroconf, python-py7zr, python-pychm, python-pycryptodome, libjpeg, and libjxr. Replace all Python 2 dependencies with their Python 3 equivalents. [arguments]: Build with the default Python and adjust custom phases accordingly. Adjust the 'configure' phase to changes in how Calibre uses SIP, and patch lookup paths for libjpeg and libjxr. Rename the 'build-extra' phase to 'install-rapydscript', and run it after the 'install' phase. Adjust it for Calibre 5.14.0. * gnu/packages/patches/calibre-no-updates-dialog.patch, gnu/packages/patches/calibre-remove-test-sqlite.patch, gnu/packages/patches/calibre-remove-test-unrar.patch: Adjust patches for Calibre 5.14.0.
26 lines
1.2 KiB
Diff
26 lines
1.2 KiB
Diff
From 19e8d7701c302b0eca4c638705a6db625352caa3 Mon Sep 17 00:00:00 2001
|
|
From: Brendan Tildesley <mail@brendan.scot>
|
|
Date: Thu, 25 Feb 2021 12:17:30 +1100
|
|
Subject: [PATCH] Don't check for updates.
|
|
|
|
---
|
|
src/calibre/gui2/main.py | 4 ++--
|
|
1 file changed, 2 insertions(+), 2 deletions(-)
|
|
|
|
diff --git a/src/calibre/gui2/main.py b/src/calibre/gui2/main.py
|
|
index 776f8bebfb..4302716d7e 100644
|
|
--- a/src/calibre/gui2/main.py
|
|
+++ b/src/calibre/gui2/main.py
|
|
@@ -59,8 +59,8 @@ def option_parser():
|
|
help=_('Start minimized to system tray.'))
|
|
parser.add_option('-v', '--verbose', default=0, action='count',
|
|
help=_('Ignored, do not use. Present only for legacy reasons'))
|
|
- parser.add_option('--no-update-check', default=False, action='store_true',
|
|
- help=_('Do not check for updates'))
|
|
+ parser.add_option('--update-check', dest='no_update_check', default=True, action='store_false',
|
|
+ help=_('Check for updates'))
|
|
parser.add_option('--ignore-plugins', default=False, action='store_true',
|
|
help=_('Ignore custom plugins, useful if you installed a plugin'
|
|
' that is preventing calibre from starting'))
|
|
--
|
|
2.30.1
|