mirror of
https://git.in.rschanz.org/ryan77627/guix.git
synced 2024-11-07 07:26:13 -05:00
049a1714fc
* gnu/packages/patches/fplll-std-fenv.patch: New patch. * gnu/local.mk (dist_patch_DATA): Register patch. * gnu/packages/algebra.scm (fplll): Use patch and move all inputs to propagated-inputs.
18 lines
616 B
Diff
18 lines
616 B
Diff
See https://github.com/fplll/fplll/issues/444
|
|
|
|
--- fplll-5.3.3-checkout.old/fplll/enum/enumerate_base.h 2020-09-23 13:55:27.833769823 +0200
|
|
+++ fplll-5.3.3-checkout/fplll/enum/enumerate_base.h 2020-09-23 13:56:14.313771769 +0200
|
|
@@ -127,10 +127,10 @@
|
|
int rounding_backup;
|
|
void save_rounding()
|
|
{
|
|
- rounding_backup = std::fegetround();
|
|
- std::fesetround(FE_TONEAREST);
|
|
+ rounding_backup = fegetround();
|
|
+ fesetround(FE_TONEAREST);
|
|
}
|
|
- void restore_rounding() { std::fesetround(rounding_backup); }
|
|
+ void restore_rounding() { fesetround(rounding_backup); }
|
|
|
|
inline bool next_pos_up()
|
|
{
|