mirror of
https://git.in.rschanz.org/ryan77627/guix.git
synced 2024-11-07 07:26:13 -05:00
c0f10a5dd4
* gnu/packages/rocm.scm (rocm-opencl-runtime): New variable. * gnu/packages/patches/rocm-opencl-runtime-3.10.0-add-rocclr-include-directories.patch, gnu/packages/patches/rocm-opencl-runtime-4.3-noclinfo.patch, gnu/packages/patches/rocm-opencl-runtime-4.3-nocltrace.patch, gnu/packages/patches/rocm-opencl-runtime-4.3-noopencl.patch: New files. * gnu/local.mk (dist_patch_DATA): Add them.
28 lines
825 B
Diff
28 lines
825 B
Diff
Do not build and install clinfo.
|
|
|
|
diff --git a/CMakeLists.txt.orig b/CMakeLists.txt
|
|
index 76847d3..3f62bfe 100644
|
|
--- a/CMakeLists.txt.orig
|
|
+++ b/CMakeLists.txt
|
|
@@ -72,7 +72,7 @@ find_package(ROCclr REQUIRED CONFIG
|
|
|
|
add_subdirectory(khronos/icd)
|
|
add_subdirectory(amdocl)
|
|
-add_subdirectory(tools/clinfo)
|
|
+#add_subdirectory(tools/clinfo)
|
|
add_subdirectory(tools/cltrace)
|
|
if(BUILD_TESTS)
|
|
add_subdirectory(tests/ocltst)
|
|
@@ -108,9 +108,9 @@ endif()
|
|
###--- Packaging ------------------------------------------------------------###
|
|
|
|
# MAIN package
|
|
-install(PROGRAMS $<TARGET_FILE:clinfo>
|
|
- DESTINATION bin
|
|
- COMPONENT MAIN)
|
|
+#install(PROGRAMS $<TARGET_FILE:clinfo>
|
|
+# DESTINATION bin
|
|
+# COMPONENT MAIN)
|
|
install(PROGRAMS $<TARGET_FILE:cltrace>
|
|
DESTINATION lib
|
|
COMPONENT MAIN)
|