mirror of
https://git.in.rschanz.org/ryan77627/guix.git
synced 2024-11-08 16:06:16 -05:00
e9a041577a
* gnu/packages/messaging.scm (telegram-purple): New variable. * gnu/packages/patches/telegram-purple-adjust-test.patch: New file. * gnu/local.mk (dist_patch_DATA): Add it. Co-authored-by: Ludovic Courtès <ludo@gnu.org>
14 lines
802 B
Diff
14 lines
802 B
Diff
This test incorrectly expects the libpurple search path to initially
|
|
contain exactly one element. Remove this incorrect assertion.
|
|
|
|
--- telegram-purple-1.3.1-checkout/test/loadtest.c 2018-10-27 16:25:06.258459600 +0200
|
|
+++ telegram-purple-1.3.1-checkout/test/loadtest.c 2018-10-27 16:25:11.830434770 +0200
|
|
@@ -156,7 +156,7 @@ static void tdf_inject_plugin (void) {
|
|
printf ("Injecting our module into purple_plugins_* ...\n");
|
|
purple_plugins_init ();
|
|
GList *search_paths = purple_plugins_get_search_paths ();
|
|
- assert (!search_paths->prev && !search_paths->next && search_paths->data);
|
|
+ assert (!search_paths->prev && search_paths->data);
|
|
GList *new_paths = g_list_append (search_paths, g_strdup ("bin/"));
|
|
assert (new_paths == search_paths);
|
|
// Load "my" path before the default.
|