mirror of
https://git.in.rschanz.org/ryan77627/guix.git
synced 2024-11-07 23:46:13 -05:00
e4d5b509fe
* gnu/packages/patches/isc-dhcp-gcc-compat.patch: New file. * gnu/local.mk (dist_patch_DATA): Adjust accordingly. * gnu/packages/admin.scm (isc-dhcp)[source](patches): New field.
72 lines
2.4 KiB
Diff
72 lines
2.4 KiB
Diff
Add minor fixes for compiling with GCC 10.
|
|
|
|
Taken from upstream:
|
|
https://gitlab.isc.org/isc-projects/dhcp/-/commit/6c7e61578b1b449272dbb40dd8b98d03dad8a57a
|
|
|
|
diff --git a/client/dhclient.c b/client/dhclient.c
|
|
--- a/client/dhclient.c
|
|
+++ b/client/dhclient.c
|
|
@@ -83,8 +83,9 @@ static const char message [] = "Internet Systems Consortium DHCP Client";
|
|
static const char url [] = "For info, please visit https://www.isc.org/software/dhcp/";
|
|
#endif /* UNIT_TEST */
|
|
|
|
-u_int16_t local_port = 0;
|
|
-u_int16_t remote_port = 0;
|
|
+extern u_int16_t local_port;
|
|
+extern u_int16_t remote_port;
|
|
+
|
|
#if defined(DHCPv6) && defined(DHCP4o6)
|
|
int dhcp4o6_state = -1; /* -1 = stopped, 0 = polling, 1 = started */
|
|
#endif
|
|
diff --git a/common/discover.c b/common/discover.c
|
|
--- a/common/discover.c
|
|
+++ b/common/discover.c
|
|
@@ -45,8 +45,8 @@ struct interface_info *fallback_interface = 0;
|
|
|
|
int interfaces_invalidated;
|
|
int quiet_interface_discovery;
|
|
-u_int16_t local_port;
|
|
-u_int16_t remote_port;
|
|
+u_int16_t local_port = 0;
|
|
+u_int16_t remote_port = 0;
|
|
u_int16_t relay_port = 0;
|
|
int dhcpv4_over_dhcpv6 = 0;
|
|
int (*dhcp_interface_setup_hook) (struct interface_info *, struct iaddr *);
|
|
diff --git a/relay/dhcrelay.c b/relay/dhcrelay.c
|
|
--- a/relay/dhcrelay.c
|
|
+++ b/relay/dhcrelay.c
|
|
@@ -95,8 +95,8 @@ enum { forward_and_append, /* Forward and append our own relay option. */
|
|
forward_untouched, /* Forward without changes. */
|
|
discard } agent_relay_mode = forward_and_replace;
|
|
|
|
-u_int16_t local_port;
|
|
-u_int16_t remote_port;
|
|
+extern u_int16_t local_port;
|
|
+extern u_int16_t remote_port;
|
|
|
|
/* Relay agent server list. */
|
|
struct server_list {
|
|
diff --git a/server/mdb.c b/server/mdb.c
|
|
--- a/server/mdb.c
|
|
+++ b/server/mdb.c
|
|
@@ -67,7 +67,7 @@ static host_id_info_t *host_id_info = NULL;
|
|
|
|
int numclasseswritten;
|
|
|
|
-omapi_object_type_t *dhcp_type_host;
|
|
+extern omapi_object_type_t *dhcp_type_host;
|
|
|
|
isc_result_t enter_class(cd, dynamicp, commit)
|
|
struct class *cd;
|
|
diff --git a/server/mdb6.c b/server/mdb6.c
|
|
--- a/server/mdb6.c
|
|
+++ b/server/mdb6.c
|
|
@@ -1945,7 +1945,7 @@ create_prefix6(struct ipv6_pool *pool, struct iasubopt **pref,
|
|
}
|
|
new_ds.data = new_ds.buffer->data;
|
|
memcpy(new_ds.buffer->data, ds.data, ds.len);
|
|
- memcpy(new_ds.buffer->data + ds.len, &tmp, sizeof(tmp));
|
|
+ memcpy(&new_ds.buffer->data[0] + ds.len, &tmp, sizeof(tmp));
|
|
data_string_forget(&ds, MDL);
|
|
data_string_copy(&ds, &new_ds, MDL);
|
|
data_string_forget(&new_ds, MDL);
|