mirror of
https://git.in.rschanz.org/ryan77627/guix.git
synced 2024-11-08 07:56:16 -05:00
0fd6138175
Transfer the NixOS patches for kpackage as of 2018-02-17: - Allow external paths. - Make QDirIterator follow symlinks. Decided to use a patch for one of the "allow external paths" changes since 'substitute*' seems not to be robust enough. * gnu/packages/patches/kpackage-allow-external-paths.patch: New file. * gnu/local.mk (dist_patch_DATA): Add it. * gnu/packages/kde-frameworks.scm(kpackage)[source]: Use it. <patch>: New phase.
13 lines
399 B
Diff
13 lines
399 B
Diff
diff --git a/src/kpackage/package.cpp b/src/kpackage/package.cpp
|
|
index 5aec9fd..b15c933 100644
|
|
--- a/src/kpackage/package.cpp
|
|
+++ b/src/kpackage/package.cpp
|
|
@@ -820,7 +820,7 @@ PackagePrivate::PackagePrivate()
|
|
: QSharedData(),
|
|
fallbackPackage(nullptr),
|
|
metadata(nullptr),
|
|
- externalPaths(false),
|
|
+ externalPaths(true),
|
|
valid(false),
|
|
checkedValid(false)
|
|
{
|