mirror of
https://git.in.rschanz.org/ryan77627/guix.git
synced 2024-11-08 07:56:16 -05:00
5f3f703918
* gnu/packages/patches/glibc-bootstrap-system.patch, gnu/packages/patches/glibc-supported-locales.patch: Adjust for glibc 2.29. * gnu/packages/patches/glibc-2.28-supported-locales.patch, gnu/packages/patches/glibc-CVE-2019-7309.patch, gnu/packages/patches/glibc-CVE-2019-9169.patch, gnu/packages/patches/glibc-2.29-git-updates.patch: New files. * gnu/local.mk (dist_patch_DATA): Adjust accordingly. * gnu/packages/base.scm (glibc): Update to 2.29. [source](patches): Add 'glibc-CVE-2019-7309.patch', 'glibc-CVE-2019-9169.patch', and 'glibc-2.29-git-updates.patch'. Remove 'glibc-hurd-magic-pid.patch'. [native-inputs]: Add PYTHON-MINIMAL. (glibc-2.28): New public variable. * gnu/packages/commencement.scm (expat-sans-tests, python-boot0): New variables. (glibc-final-with-bootstrap-bash)[native-inputs]: Add PYTHON-BOOT0. * gnu/packages/python.scm (python-3.7)[arguments]: Disable test that fails with glibc 2.29.
33 lines
1 KiB
Diff
33 lines
1 KiB
Diff
This patch is taken from debian's glibc package (generate-supported.mk).
|
|
It install the localedata/SUPPORTED file of the glibc. This file lists
|
|
all the supported locales of the glibc.
|
|
|
|
diff --git a/localedata/Makefile.old b/localedata/Makefile
|
|
index 34877c0..a61d9b9 100644
|
|
--- a/localedata/Makefile.old
|
|
+++ b/localedata/Makefile
|
|
@@ -91,7 +91,8 @@ endif
|
|
# Files to install.
|
|
install-others := $(addprefix $(inst_i18ndir)/, \
|
|
$(addsuffix .gz, $(charmaps)) \
|
|
- $(locales))
|
|
+ $(locales)) \
|
|
+ $(inst_i18ndir)/SUPPORTED
|
|
|
|
tests: $(objdir)/iconvdata/gconv-modules
|
|
|
|
@@ -195,6 +196,14 @@ endif
|
|
|
|
include SUPPORTED
|
|
|
|
+$(inst_i18ndir)/SUPPORTED: SUPPORTED $(+force)
|
|
+ for locale in $(SUPPORTED-LOCALES); do \
|
|
+ [ $$locale = true ] && continue; \
|
|
+ echo $$locale | sed 's,/, ,' >> LOCALES; \
|
|
+ done
|
|
+ $(make-target-directory)
|
|
+ $(INSTALL_DATA) LOCALES $@
|
|
+
|
|
INSTALL-SUPPORTED-LOCALES=$(addprefix install-, $(SUPPORTED-LOCALES))
|
|
|
|
# Sometimes the whole collection of locale files should be installed.
|