mirror of
https://git.in.rschanz.org/ryan77627/guix.git
synced 2024-11-08 16:06:16 -05:00
7439173f2c
* gnu/packages/python.scm (python-unittest2): Update to 1.1.0. [source]: Use PYPI-URI. Add two patches. [arguments]: Add phase to run tests. [propagated-inputs]: Add PYTHON-SIX and PYTHON-TRACEBACK2. (python2-unittest2): Use 'package-with-python2'. * gnu/packages/patches/python2-unittest2-remove-argparse.patch: Rename to ... * gnu/packages/patches/python2-unittest2-remove-argparse.patch: ... this. * gnu/packages/patches/python-unittest2-python3-compat.patch: New file. * gnu/local.mk (dist_patch_DATA): Adjust accordingly.
34 lines
1.5 KiB
Diff
34 lines
1.5 KiB
Diff
Skip tests that fail with newer versions of Python.
|
|
|
|
Patch copied from Gentoo:
|
|
|
|
https://gitweb.gentoo.org/repo/gentoo.git/tree/dev-python/unittest2/files/unittest2-1.1.0-python3.5-test.patch
|
|
|
|
diff --git a/unittest2/test/test_loader.py b/unittest2/test/test_loader.py
|
|
index 683f662..347eea5 100644
|
|
--- a/unittest2/test/test_loader.py
|
|
+++ b/unittest2/test/test_loader.py
|
|
@@ -509,6 +509,7 @@ class Test_TestLoader(unittest2.TestCase):
|
|
#
|
|
# What happens when an impossible name is given, relative to the provided
|
|
# `module`?
|
|
+ @unittest.skipIf(sys.version_info[:2] >= (3, 5), "python 3.5 has problems here")
|
|
def test_loadTestsFromName__relative_malformed_name(self):
|
|
loader = unittest.TestLoader()
|
|
|
|
@@ -811,6 +812,7 @@ class Test_TestLoader(unittest2.TestCase):
|
|
# TestCase or TestSuite instance."
|
|
#
|
|
# What happens when presented with an impossible module name?
|
|
+ @unittest.skipIf(sys.version_info[:2] >= (3, 5), "python 3.5 has problems here")
|
|
def test_loadTestsFromNames__malformed_name(self):
|
|
loader = unittest2.TestLoader()
|
|
|
|
@@ -918,6 +920,7 @@ class Test_TestLoader(unittest2.TestCase):
|
|
# "The method optionally resolves name relative to the given module"
|
|
#
|
|
# What happens when presented with an impossible attribute name?
|
|
+ @unittest.skipIf(sys.version_info[:2] >= (3, 5), "python 3.5 has problems here")
|
|
def test_loadTestsFromNames__relative_malformed_name(self):
|
|
loader = unittest.TestLoader()
|
|
|