mirror of
https://git.in.rschanz.org/ryan77627/guix.git
synced 2024-11-08 07:56:16 -05:00
942c788949
* gnu/packages/patches/ilmbase-fix-tests.patch: Adjust for new origin. * gnu/packages/patches/ilmbase-openexr-pkg-config.patch: New file. * gnu/local.mk (dist_patch_DATA): Adjust accordingly. * gnu/packages/graphics.scm (ilmbase): Update to 2.4.0. [source]: Change to GIT-FETCH, as tarballs are no longer provided. Add new patch. [build-system]: Change to CMAKE-BUILD-SYSTEM. [arguments]: Add phase to enter the correct source directory. * gnu/packages/graphics.scm (openexr): Update to 2.4.0. [source]: Inherit from ILMBASE, which comes from the same repository. [build-system]: Change to CMAKE-BUILD-SYSTEM. [arguments]: Add phase to enter the correct source directory. * gnu/packages/gstreamer.scm (gst-plugins-bad)[arguments]: Enable C++11. * gnu/packages/image-processing.scm (opencv)[arguments]: Likewise.
40 lines
1.7 KiB
Diff
40 lines
1.7 KiB
Diff
Fix pkg-config files when using the CMake build system.
|
|
|
|
Upstream bug report:
|
|
https://github.com/openexr/openexr/issues/567
|
|
|
|
diff --git a/IlmBase/config/CMakeLists.txt b/IlmBase/config/CMakeLists.txt
|
|
index 508176a..9e6ab91 100644
|
|
--- a/IlmBase/config/CMakeLists.txt
|
|
+++ b/IlmBase/config/CMakeLists.txt
|
|
@@ -71,9 +71,9 @@ if(ILMBASE_INSTALL_PKG_CONFIG)
|
|
# use a helper function to avoid variable pollution, but pretty simple
|
|
function(ilmbase_pkg_config_help pcinfile)
|
|
set(prefix ${CMAKE_INSTALL_PREFIX})
|
|
- set(exec_prefix ${CMAKE_INSTALL_BINDIR})
|
|
- set(libdir ${CMAKE_INSTALL_LIBDIR})
|
|
- set(includedir ${CMAKE_INSTALL_INCLUDEDIR})
|
|
+ set(exec_prefix ${CMAKE_INSTALL_FULL_BINDIR})
|
|
+ set(libdir ${CMAKE_INSTALL_FULL_LIBDIR})
|
|
+ set(includedir ${CMAKE_INSTALL_FULL_INCLUDEDIR})
|
|
set(LIB_SUFFIX_DASH ${ILMBASE_LIB_SUFFIX})
|
|
if(TARGET Threads::Threads)
|
|
# hrm, can't use properties as they end up as generator expressions
|
|
diff --git a/OpenEXR/config/CMakeLists.txt b/OpenEXR/config/CMakeLists.txt
|
|
index 1ef829a..b8dc141 100644
|
|
--- a/OpenEXR/config/CMakeLists.txt
|
|
+++ b/OpenEXR/config/CMakeLists.txt
|
|
@@ -72,9 +72,9 @@ if(OPENEXR_INSTALL_PKG_CONFIG)
|
|
# use a helper function to avoid variable pollution, but pretty simple
|
|
function(openexr_pkg_config_help pcinfile)
|
|
set(prefix ${CMAKE_INSTALL_PREFIX})
|
|
- set(exec_prefix ${CMAKE_INSTALL_BINDIR})
|
|
- set(libdir ${CMAKE_INSTALL_LIBDIR})
|
|
- set(includedir ${CMAKE_INSTALL_INCLUDEDIR})
|
|
+ set(exec_prefix ${CMAKE_INSTALL_FULL_BINDIR})
|
|
+ set(libdir ${CMAKE_INSTALL_FULL_LIBDIR})
|
|
+ set(includedir ${CMAKE_INSTALL_FULL_INCLUDEDIR})
|
|
set(LIB_SUFFIX_DASH ${OPENEXR_LIB_SUFFIX})
|
|
if(TARGET Threads::Threads)
|
|
# hrm, can't use properties as they end up as generator expressions
|
|
|