mirror of
https://git.in.rschanz.org/ryan77627/guix.git
synced 2025-01-27 04:59:27 -05:00
75824be1ac
* gnu/packages/patches/librewolf-add-paths-to-rdd-allowlist.patch: New file. * gnu/local.mk (dist_patch_DATA): Register it here. Change-Id: Ice417148b0ddf9acf0062eb6d16a875a81e350e6
11 lines
473 B
Diff
11 lines
473 B
Diff
--- a/security/sandbox/linux/broker/SandboxBrokerPolicyFactory.cpp
|
|
+++ b/security/sandbox/linux/broker/SandboxBrokerPolicyFactory.cpp
|
|
@@ -920,6 +920,8 @@
|
|
policy->AddDir(rdonly, "/usr/lib64");
|
|
policy->AddDir(rdonly, "/run/opengl-driver/lib");
|
|
policy->AddDir(rdonly, "/nix/store");
|
|
+ policy->AddDir(rdonly, "/gnu/store");
|
|
+ policy->AddDir(rdonly, "/run/current-system/profile/lib");
|
|
|
|
// Bug 1647957: memory reporting.
|
|
AddMemoryReporting(policy.get(), aPid);
|