mirror of
https://git.in.rschanz.org/ryan77627/guix.git
synced 2025-01-03 18:09:18 -05:00
c0895371c5
Fixes <https://issues.guix.gnu.org/65177>. Reported by Adrien 'neox' Bourmault <neox@gnu.org>. * gnu/packages/patches/lvm2-no-systemd.patch: New file. * gnu/packages/linux.scm (lvm2)[source]: Apply patch. * gnu/local.mk: Register new patch. Signed-off-by: Simon Tournier <zimon.toutoune@gmail.com> Change-Id: I6b9d583f5914cc127c067829b5891827c04608cb
20 lines
1 KiB
Diff
20 lines
1 KiB
Diff
Fixes <https://issues.guix.gnu.org/65177>.
|
|
|
|
Run 'vgchange' directly instead of attempting to run it via 'systemd-run' as
|
|
the udev rules included in lvm2 >= 2.03.14 do.
|
|
|
|
diff --git a/udev/69-dm-lvm.rules.in b/udev/69-dm-lvm.rules.in
|
|
index ff15681..f9e5b70 100644
|
|
--- a/udev/69-dm-lvm.rules.in
|
|
+++ b/udev/69-dm-lvm.rules.in
|
|
@@ -75,8 +75,8 @@ LABEL="lvm_scan"
|
|
# TODO: adjust the output of vgchange -aay so that
|
|
# it's better suited to appearing in the journal.
|
|
|
|
-IMPORT{program}="(LVM_EXEC)/lvm pvscan --cache --listvg --checkcomplete --vgonline --autoactivation event --udevoutput --journal=output $env{DEVNAME}"
|
|
-ENV{LVM_VG_NAME_COMPLETE}=="?*", RUN+="(SYSTEMDRUN) --no-block --property DefaultDependencies=no --unit lvm-activate-$env{LVM_VG_NAME_COMPLETE} (LVM_EXEC)/lvm vgchange -aay --autoactivation event $env{LVM_VG_NAME_COMPLETE}"
|
|
+IMPORT{program}="(LVM_EXEC)/lvm pvscan --cache --listvg
|
|
+ENV{LVM_VG_NAME_COMPLETE}=="?*", RUN+="(SYSTEMDRUN) --no-block lvm-activate-$env{LVM_VG_NAME_COMPLETE} (LVM_EXEC)/lvm vgchange -aay
|
|
GOTO="lvm_end"
|
|
|
|
LABEL="lvm_end"
|