mirror of
https://git.in.rschanz.org/ryan77627/guix.git
synced 2024-11-18 04:37:36 -05:00
6805ab3290
* gnu/packages/patches/freecad-boost-serialization.patch: New file. * gnu/local.mk (dist_patch_DATA): Add it. * gnu/packages/engineering.scm (freecad) [source]: Use it. [arguments]{#:configure-flags}: Turn it into a GEXP and adapt it.
27 lines
827 B
Diff
27 lines
827 B
Diff
Taken from: https://github.com/archlinux/svntogit-community/blob/packages/freecad/trunk/freecad-boost.patch.
|
|
|
|
Index: FreeCAD-0.19.2/CMakeLists.txt
|
|
===================================================================
|
|
--- a/CMakeLists.txt
|
|
+++ b/CMakeLists.txt
|
|
@@ -46,6 +46,7 @@ if(NOT FREECAD_LIBPACK_USE OR FREECAD_LI
|
|
SetupPCL()
|
|
SetupPybind11()
|
|
SetupBoost()
|
|
+ set(Boost_LIBRARIES_App ${Boost_LIBRARIES})
|
|
SetupXercesC()
|
|
find_package(ZLIB REQUIRED)
|
|
find_package(PyCXX REQUIRED)
|
|
Index: FreeCAD-0.19.2/src/App/CMakeLists.txt
|
|
===================================================================
|
|
--- a/src/App/CMakeLists.txt
|
|
+++ b/src/App/CMakeLists.txt
|
|
@@ -59,7 +59,7 @@ include_directories(
|
|
|
|
set(FreeCADApp_LIBS
|
|
FreeCADBase
|
|
- ${Boost_LIBRARIES}
|
|
+ ${Boost_LIBRARIES_App}
|
|
)
|
|
|
|
if (BUILD_QT5)
|