mirror of
https://git.in.rschanz.org/ryan77627/guix.git
synced 2024-12-25 22:08:16 -05:00
745177cea5
* gnu/packages/patches/gcc-7-libsanitizer-fsconfig-command.patch: New file. * gnu/packages/gcc.scm (gcc-7)[source]: Use it. * gnu/local.mk (dist_patch_DATA): Add it. Change-Id: Ifa273b92573281c34d83e5fb8cd68734ef02c7fd
32 lines
1.4 KiB
Diff
32 lines
1.4 KiB
Diff
Avoid redefinition of ‘enum fsconfig_command’ and ‘struct mount_attr’ in
|
||
libsanitizer with glibc 2.38.
|
||
|
||
https://github.com/draperlaboratory/hope-llvm-project/commit/d8daef856858ecbd19898c3e0de63e76221e2baa
|
||
https://github.com/llvm/llvm-project/issues/56421
|
||
https://gcc.gnu.org/bugzilla/show_bug.cgi?id=113181
|
||
|
||
--- a/libsanitizer/sanitizer_common/sanitizer_platform_limits_posix.cc
|
||
+++ b/libsanitizer/sanitizer_common/sanitizer_platform_limits_posix.cc
|
||
@@ -73,7 +73,6 @@
|
||
#include <sys/vt.h>
|
||
#include <linux/cdrom.h>
|
||
#include <linux/fd.h>
|
||
-#include <linux/fs.h>
|
||
#include <linux/hdreg.h>
|
||
#include <linux/input.h>
|
||
#include <linux/ioctl.h>
|
||
@@ -876,10 +875,10 @@ unsigned struct_ElfW_Phdr_sz = sizeof(Elf_Phdr);
|
||
unsigned IOCTL_EVIOCGPROP = IOCTL_NOT_PRESENT;
|
||
unsigned IOCTL_EVIOCSKEYCODE_V2 = IOCTL_NOT_PRESENT;
|
||
#endif
|
||
- unsigned IOCTL_FS_IOC_GETFLAGS = FS_IOC_GETFLAGS;
|
||
- unsigned IOCTL_FS_IOC_GETVERSION = FS_IOC_GETVERSION;
|
||
- unsigned IOCTL_FS_IOC_SETFLAGS = FS_IOC_SETFLAGS;
|
||
- unsigned IOCTL_FS_IOC_SETVERSION = FS_IOC_SETVERSION;
|
||
+ unsigned IOCTL_FS_IOC_GETFLAGS = _IOR('f', 1, long);
|
||
+ unsigned IOCTL_FS_IOC_GETVERSION = _IOR('v', 1, long);
|
||
+ unsigned IOCTL_FS_IOC_SETFLAGS = _IOW('f', 2, long);
|
||
+ unsigned IOCTL_FS_IOC_SETVERSION = _IOW('v', 2, long);
|
||
unsigned IOCTL_GIO_CMAP = GIO_CMAP;
|
||
unsigned IOCTL_GIO_FONT = GIO_FONT;
|
||
unsigned IOCTL_GIO_UNIMAP = GIO_UNIMAP;
|