mirror of
https://git.in.rschanz.org/ryan77627/guix.git
synced 2024-12-25 22:08:16 -05:00
48ea1a2b3b
* gnu/packages/patches/openjdk-10-char-reproducibility.patch: New file. * gnu/packages/patches/openjdk-10-classlist-reproducibility.patch: New file. * gnu/packages/patches/openjdk-10-corba-reproducibility.patch: New file. * gnu/packages/patches/openjdk-10-jar-reproducibility.patch: New file. * gnu/packages/patches/openjdk-10-jtask-reproducibility.patch: New file. * gnu/packages/patches/openjdk-10-module-reproducibility.patch: New file. * gnu/packages/patches/openjdk-10-module3-reproducibility.patch: New file. * gnu/packages/patches/openjdk-10-module4-reproducibility.patch: New file. * gnu/packages/java.scm (openjdk10)[source]: Add patches. [arguments]<#:phases>[remove-timestamping]: New phase. * gnu/local.mk (dist_patch_DATA): Add patches. Signed-off-by: Maxim Cournoyer <maxim.cournoyer@gmail.com>
27 lines
1.3 KiB
Diff
27 lines
1.3 KiB
Diff
--- orig/jdk-6fa770f9f8ab/make/GenerateLinkOptData.gmk 2022-04-04 17:16:29.365930149 +0200
|
|
+++ jdk-6fa770f9f8ab/make/GenerateLinkOptData.gmk 2022-04-04 17:16:54.954624358 +0200
|
|
@@ -61,11 +61,12 @@
|
|
$(call MakeDir, $(LINK_OPT_DIR))
|
|
$(call LogInfo, Generating $(patsubst $(OUTPUTDIR)/%, %, $@))
|
|
$(call LogInfo, Generating $(patsubst $(OUTPUTDIR)/%, %, $(JLI_TRACE_FILE)))
|
|
- $(FIXPATH) $(INTERIM_IMAGE_DIR)/bin/java -XX:DumpLoadedClassList=$@ \
|
|
+ $(FIXPATH) $(INTERIM_IMAGE_DIR)/bin/java -XX:DumpLoadedClassList=$@.tmp \
|
|
-Djava.lang.invoke.MethodHandle.TRACE_RESOLVE=true \
|
|
-cp $(SUPPORT_OUTPUTDIR)/classlist.jar \
|
|
build.tools.classlist.HelloClasslist \
|
|
$(LOG_DEBUG) 2>&1 > $(JLI_TRACE_FILE)
|
|
+ sort $@.tmp > $@
|
|
|
|
# The jli trace is created by the same recipe as classlist. By declaring these
|
|
# dependencies, make will correctly rebuild both jli trace and classlist
|
|
--- orig/jdk-6fa770f9f8ab/make/gendata/Gendata-jdk.compiler.gmk 2022-04-13 19:24:10.191682716 +0200
|
|
+++ jdk-6fa770f9f8ab/make/gendata/Gendata-jdk.compiler.gmk 2022-04-13 20:58:57.891368216 +0200
|
|
@@ -83,6 +83,8 @@
|
|
$(CT_MODULESOURCEPATH) \
|
|
$(CT_MODULES) \
|
|
>$(@D)/A/system-modules
|
|
+ # Make files reproducible
|
|
+ find $(@D) -exec $(TOUCH) -h -c -t 197001010000.01 {} \;
|
|
$(TOUCH) $@
|
|
|
|
# Can't generate ct.sym directly into modules libs as the SetupJarArchive macro
|