mirror of
https://git.in.rschanz.org/ryan77627/guix.git
synced 2024-11-16 03:45:24 -05:00
31cf1530a4
Update the following patch that no longer applies since the 40.1 version. * gnu/packages/patches/gdm-wayland-session-wrapper-from-env.patch: Update it.
35 lines
1.9 KiB
Diff
35 lines
1.9 KiB
Diff
Get wayland-session wrapper from environment.
|
|
|
|
---
|
|
daemon/gdm-session.c | 6 ++++--
|
|
1 file changed, 4 insertions(+), 2 deletions(-)
|
|
|
|
diff --git a/daemon/gdm-session.c b/daemon/gdm-session.c
|
|
index 4e303e70..1deca4e9 100644
|
|
--- a/daemon/gdm-session.c
|
|
+++ b/daemon/gdm-session.c
|
|
@@ -2888,8 +2888,9 @@ gdm_session_start_session (GdmSession *self,
|
|
allow_remote_connections? "--allow-remote-connections " : "",
|
|
command);
|
|
} else {
|
|
- program = g_strdup_printf (LIBEXECDIR "/gdm-wayland-session %s\"%s\"",
|
|
+ program = g_strdup_printf (LIBEXECDIR "/gdm-wayland-session %s\"%s %s\"",
|
|
register_session ? "--register-session " : "",
|
|
+ g_getenv ("GDM_WAYLAND_SESSION"),
|
|
command);
|
|
}
|
|
} else if (run_xsession_script) {
|
|
@@ -2942,8 +2942,9 @@
|
|
register_session ? "--register-session " : "",
|
|
self->selected_program);
|
|
} else {
|
|
- program = g_strdup_printf (LIBEXECDIR "/gdm-wayland-session %s\"dbus-run-session -- %s\"",
|
|
+ program = g_strdup_printf (LIBEXECDIR "/gdm-wayland-session %s\"dbus-run-session -- %s %s\"",
|
|
register_session ? "--register-session " : "",
|
|
+ g_getenv ("GDM_WAYLAND_SESSION"),
|
|
self->selected_program);
|
|
}
|
|
} else {
|
|
--
|
|
2.33.0
|
|
|