mirror of
https://git.in.rschanz.org/ryan77627/guix.git
synced 2024-11-16 03:45:24 -05:00
67c30ff8ad
All packages updated at the same time as they have a shared version. rocclr is no longer a stand-alone package, so the previous version is kept as rocclr-4 and the current version is just the source, rocclr-src, needed by rocm-opencl-runtime. * gnu/packages/patches/rocm-opencl-runtime-3.10.0-includes.patch, gnu/packages/patches/rocm-opencl-runtime-4.3-nocltrace.patch: Delete files. * gnu/local.mk (dist_patch_DATA): Remove them. * gnu/packages/patches/rocm-comgr-3.1.0-dependencies.patch, gnu/packages/patches/rocm-opencl-runtime-4.3-noclinfo.patch, gnu/packages/patches/rocm-opencl-runtime-4.3-noopencl.patch: Update patches. * gnu/packages/rocm.scm (rocm-cmake, rocm-device-libs, rocm-comgr, roct-thunk-interface, rocr-runtime, rocm-opencl-runtime, rocminfo, rocm-bandwidth-test): Update to 5.1.3. (roct-thunk-interface)[inputs]: Add libdrm. [native-inputs]: Add gcc:lib and pkg-config. (rocclr-src): New variable. (rocclr-4): New variable (previous version of the package). (rocm-opencl-runtime)[source]: Remove obsolete patches. [arguments]: Rewrite with gexps. Add needed #:configure-flags. [inputs]: Remove rocclr, add numactl. Signed-off-by: Ludovic Courtès <ludo@gnu.org>
70 lines
2.6 KiB
Diff
70 lines
2.6 KiB
Diff
Do not build and install libOpenCL.
|
|
|
|
--- b/CMakeLists.txt
|
|
+++ b/CMakeLists.txt
|
|
@@ -15,9 +15,9 @@ option(FILE_REORG_BACKWARD_COMPATIBILITY "Enable File Reorganization backward co
|
|
|
|
|
|
set(OPENCL_ICD_LOADER_HEADERS_DIR "${CMAKE_CURRENT_LIST_DIR}/khronos/headers/opencl2.2" CACHE PATH "")
|
|
-add_subdirectory(khronos/icd)
|
|
+#add_subdirectory(khronos/icd)
|
|
add_subdirectory(amdocl)
|
|
add_subdirectory(tools/clinfo)
|
|
add_subdirectory(tools/cltrace)
|
|
if(BUILD_TESTS)
|
|
add_subdirectory(tests/ocltst)
|
|
@@ -25,16 +25,6 @@ endif()
|
|
|
|
###--- Packaging ------------------------------------------------------------###
|
|
|
|
-# DEV package
|
|
-install(DIRECTORY "${CMAKE_CURRENT_SOURCE_DIR}/khronos/headers/opencl2.2/CL"
|
|
- DESTINATION include
|
|
- COMPONENT DEV
|
|
- USE_SOURCE_PERMISSIONS
|
|
- PATTERN cl_d3d10.h EXCLUDE
|
|
- PATTERN cl_d3d11.h EXCLUDE
|
|
- PATTERN cl_dx9_media_sharing.h EXCLUDE
|
|
- PATTERN cl_egl.h EXCLUDE)
|
|
-
|
|
#############################
|
|
# Packaging steps
|
|
#############################
|
|
@@ -53,8 +43,8 @@ if (DEFINED ROCM_PATCH_VERSION)
|
|
set(OPENCL_AMD_ICD_FILE "amdocl64_${ROCM_PATCH_VERSION}.icd")
|
|
endif()
|
|
|
|
-get_target_property(OPENCL_LIB_VERSION_MAJOR OpenCL SOVERSION)
|
|
-get_target_property(OPENCL_LIB_VERSION_STRING OpenCL VERSION)
|
|
+#get_target_property(OPENCL_LIB_VERSION_MAJOR OpenCL SOVERSION)
|
|
+#get_target_property(OPENCL_LIB_VERSION_STRING OpenCL VERSION)
|
|
|
|
#Set Package Version
|
|
set(CPACK_PACKAGE_VERSION ${PROJECT_VERSION})
|
|
diff --git a/khronos/icd/CMakeLists.txt b/khronos/icd/CMakeLists.txt
|
|
index 4bafa86..987dd6f 100644
|
|
--- a/khronos/icd/CMakeLists.txt 2020-06-07 16:05:32.425022904 +0200
|
|
+++ b/khronos/icd/CMakeLists.txt 2020-06-07 16:06:03.273022786 +0200
|
|
@@ -132,7 +132,7 @@ if (BUILD_TESTING)
|
|
add_subdirectory (test)
|
|
endif()
|
|
|
|
-install (TARGETS OpenCL
|
|
- RUNTIME DESTINATION ${CMAKE_INSTALL_BINDIR}
|
|
- ARCHIVE DESTINATION ${CMAKE_INSTALL_LIBDIR}
|
|
- LIBRARY DESTINATION ${CMAKE_INSTALL_LIBDIR})
|
|
+#install (TARGETS OpenCL
|
|
+# RUNTIME DESTINATION ${CMAKE_INSTALL_BINDIR}
|
|
+# ARCHIVE DESTINATION ${CMAKE_INSTALL_LIBDIR}
|
|
+# LIBRARY DESTINATION ${CMAKE_INSTALL_LIBDIR})
|
|
diff --git a/packaging/CMakeLists.txt b/packaging/CMakeLists.txt
|
|
index 48353eb..cd1e7c1 100644
|
|
--- a/packaging/CMakeLists.txt
|
|
+++ b/packaging/CMakeLists.txt
|
|
@@ -17,5 +17,5 @@ install(DIRECTORY ${CMAKE_SOURCE_DIR}/khronos/headers/opencl2.2/CL
|
|
PATTERN cl_dx9_media_sharing.h EXCLUDE
|
|
PATTERN cl_egl.h EXCLUDE )
|
|
|
|
-install(TARGETS OpenCL DESTINATION lib COMPONENT icd )
|
|
+#install(TARGETS OpenCL DESTINATION lib COMPONENT icd )
|
|
install(FILES ${CMAKE_SOURCE_DIR}/khronos/icd/LICENSE DESTINATION share/doc/rocm-ocl-icd COMPONENT icd)
|