mirror of
https://git.in.rschanz.org/ryan77627/guix.git
synced 2024-11-07 23:46:13 -05:00
57983029a9
Fixes <https://bugs.gnu.org/43131>. * gnu/packages/patches/xmonad-dynamic-linking.patch: New file. * gnu/local.mk (dist_patch_DATA): Add it. * gnu/packages/wm.scm (xmonad)[source]: Use it.
16 lines
724 B
Diff
16 lines
724 B
Diff
This patch is required for xmonad to make use of shared libraries.
|
|
Without it, xmonad will not work since we do not (by default) use
|
|
statically linked Haskell libraries.
|
|
|
|
diff -ruN xmonad-0.15-a/src/XMonad/Core.hs xmonad-0.15-b/src/XMonad/Core.hs
|
|
--- xmonad-0.15-a/src/XMonad/Core.hs 1969-12-31 19:00:00.000000000 -0500
|
|
+++ xmonad-0.15-b/src/XMonad/Core.hs 1969-12-31 19:00:00.000000000 -0500
|
|
@@ -681,6 +681,8 @@
|
|
compileGHC bin dir errHandle =
|
|
runProcess "ghc" ["--make"
|
|
, "xmonad.hs"
|
|
+ , "-dynamic"
|
|
+ , "-fPIC"
|
|
, "-i"
|
|
, "-ilib"
|
|
, "-fforce-recomp"
|