mirror of
https://git.in.rschanz.org/ryan77627/guix.git
synced 2025-01-06 03:17:15 -05:00
75527eb1cb
This fixes CVE-2020-6465, CVE-2020-6466, CVE-2020-6467, CVE-2020-6468, CVE-2020-6469, CVE-2020-6470, CVE-2020-6471, CVE-2020-6472, CVE-2020-6473, CVE-2020-6474, CVE-2020-6475, CVE-2020-6476, CVE-2020-6477, CVE-2020-6478, CVE-2020-6479, CVE-2020-6480, CVE-2020-6481, CVE-2020-6482, CVE-2020-6483, CVE-2020-6484, CVE-2020-6485, CVE-2020-6486, CVE-2020-6487, CVE-2020-6488, CVE-2020-6489, CVE-2020-6490, CVE-2020-6491, CVE-2020-6493, CVE-2020-6494, CVE-2020-6495, CVE-2020-6496, CVE-2020-6497, and CVE-2020-6498. * gnu/packages/patches/ungoogled-chromium-system-jsoncpp.patch, gnu/packages/patches/ungoogled-chromium-system-zlib.patch: New files. * gnu/local.mk (dist_patch_DATA): Adjust accordingly. * gnu/packages/chromium.scm (%preserved-third-party-files): Adjust for 83. (%chromium-version): Set to 83.0.4103.106. (%ungoogled-revision): Set to f08ce8b3f1300ef0750b5d6bf967b9cbbfd9a56d. (%gentoo-revision, %gentoo-patches, %debian-patches): New variables. (gentoo-patch, debian-patch): New procedures. (%chromium-origin, %ungoogled-origin): Update hashes. (ungoogled-chromium-source): Don't apply patches from %DEBIAN-ORIGIN, but take %GENTOO-PATCHES, %DEBIAN-PATCHES, and the local patch files. (ungoogled-chromium)[arguments]: Remove "enable_swiftshader=false" from #:configure-flags. Add "icu_use_data_file=false". Set CFLAGS in phase. Remove obsolete substitution. Adjust install phase to install .so files for ANGLE and Swiftshader. [native-inputs]: Change from CLANG-9 to CLANG-10. [inputs]: Replace ICU4C with ICU4C-67. (ungoogled-chromium/wayland): Remove obsolete substitution. Add "ozone_platform_x11=true" in #:configure-flags.
47 lines
1.2 KiB
Diff
47 lines
1.2 KiB
Diff
Use zlib instead of the bundled lzma_sdk.
|
|
|
|
Adapted from Debian:
|
|
https://salsa.debian.org/chromium-team/chromium/-/blob/master/debian/patches/system/zlib.patch
|
|
|
|
diff --git a/courgette/BUILD.gn b/courgette/BUILD.gn
|
|
--- a/courgette/BUILD.gn
|
|
+++ b/courgette/BUILD.gn
|
|
@@ -58,7 +58,6 @@ static_library("courgette_lib") {
|
|
|
|
deps = [
|
|
"//base",
|
|
- "//third_party/lzma_sdk",
|
|
]
|
|
|
|
public_deps = [
|
|
@@ -79,7 +78,6 @@ source_set("courgette_common") {
|
|
]
|
|
deps = [
|
|
"//base",
|
|
- "//third_party/lzma_sdk",
|
|
]
|
|
}
|
|
|
|
diff --git a/courgette/crc.cc b/courgette/crc.cc
|
|
--- a/courgette/crc.cc
|
|
+++ b/courgette/crc.cc
|
|
@@ -7,6 +7,8 @@
|
|
#include <stdint.h>
|
|
#include <stddef.h>
|
|
|
|
+#define COURGETTE_USE_CRC_LIB
|
|
+
|
|
#ifdef COURGETTE_USE_CRC_LIB
|
|
# include "zlib.h"
|
|
#else
|
|
diff --git a/third_party/perfetto/gn/BUILD.gn b/third_party/perfetto/gn/BUILD.gn
|
|
--- a/third_party/perfetto/gn/BUILD.gn
|
|
+++ b/third_party/perfetto/gn/BUILD.gn
|
|
@@ -304,7 +304,6 @@ if (enable_perfetto_zlib) {
|
|
public_configs = [ "//buildtools:zlib_config" ]
|
|
public_deps = [ "//buildtools:zlib" ]
|
|
} else {
|
|
- public_configs = [ "//third_party/zlib:zlib_config" ]
|
|
public_deps = [ "//third_party/zlib" ]
|
|
}
|
|
}
|