mirror of
https://git.in.rschanz.org/ryan77627/guix.git
synced 2024-11-15 11:25:22 -05:00
92d2205a19
Add `emacs-next' for building latest Emacs from git. * gnu/packages/emacs.scm (emacs-next): New variable. (emacs): make the autoload deletion snippet not fail when eshell/esh-groups.el does not exist. This enables reuse of the entire snippet field of `emacs' for `emacs-next'. * gnu/packages/patches/emacs27-exec-path.patch: New file. * gnu/local.mk (dist_patch_DATA): Add the above patch file to it. Signed-off-by: Ludovic Courtès <ludo@gnu.org>
18 lines
811 B
Diff
18 lines
811 B
Diff
Do not capture the build-time value of $PATH in the 'emacs' executable
|
|
since this can noticeably increase the size of the closure of Emacs
|
|
with things like GCC being referenced.
|
|
|
|
(like emacs-exec-path.patch, but for Emacs 27)
|
|
|
|
--- a/lisp/loadup.el
|
|
+++ b/lisp/loadup.el
|
|
@@ -479,7 +479,8 @@ lost after dumping")))
|
|
((equal dump-mode "dump") "emacs")
|
|
((equal dump-mode "bootstrap") "emacs")
|
|
((equal dump-mode "pbootstrap") "bootstrap-emacs.pdmp")
|
|
- (t (error "unrecognized dump mode %s" dump-mode)))))
|
|
+ (t (error "unrecognized dump mode %s" dump-mode))))
|
|
+ (exec-path nil))
|
|
(message "Dumping under the name %s" output)
|
|
(condition-case ()
|
|
(delete-file output)
|