mirror of
https://git.in.rschanz.org/ryan77627/guix.git
synced 2024-11-07 15:36:20 -05:00
4fdf3a2e6e
* gnu/packages/patches/busybox-1.31.1-fix-build-with-glibc-2.31.patch: New file * gnu/local.mk (dist_patch_DATA): Add it. * gnu/packages/busybox.scm (busybox): Update to 1.31.1. [source]: Use patch. [arguments]<#:phases>[check]: Fix test.
68 lines
2 KiB
Diff
68 lines
2 KiB
Diff
See: https://bugs.gentoo.org/708350
|
|
Author: Patrick McLean <patrick.mclean@sony.com>
|
|
Date: 2020-02-06 23:06:22 +0000
|
|
diff --git a/coreutils/date.c b/coreutils/date.c
|
|
index 3414d38ae..4ade6abb4 100644
|
|
--- a/coreutils/date.c
|
|
+++ b/coreutils/date.c
|
|
@@ -279,6 +279,9 @@ int date_main(int argc UNUSED_PARAM, char **argv)
|
|
time(&ts.tv_sec);
|
|
#endif
|
|
}
|
|
+#if !ENABLE_FEATURE_DATE_NANO
|
|
+ ts.tv_nsec = 0;
|
|
+#endif
|
|
localtime_r(&ts.tv_sec, &tm_time);
|
|
|
|
/* If date string is given, update tm_time, and maybe set date */
|
|
@@ -301,9 +304,10 @@ int date_main(int argc UNUSED_PARAM, char **argv)
|
|
if (date_str[0] != '@')
|
|
tm_time.tm_isdst = -1;
|
|
ts.tv_sec = validate_tm_time(date_str, &tm_time);
|
|
+ ts.tv_nsec = 0;
|
|
|
|
/* if setting time, set it */
|
|
- if ((opt & OPT_SET) && stime(&ts.tv_sec) < 0) {
|
|
+ if ((opt & OPT_SET) && clock_settime(CLOCK_REALTIME, &ts) < 0) {
|
|
bb_perror_msg("can't set date");
|
|
}
|
|
}
|
|
diff --git a/libbb/missing_syscalls.c b/libbb/missing_syscalls.c
|
|
index 87cf59b3d..dc40d9155 100644
|
|
--- a/libbb/missing_syscalls.c
|
|
+++ b/libbb/missing_syscalls.c
|
|
@@ -15,14 +15,6 @@ pid_t getsid(pid_t pid)
|
|
return syscall(__NR_getsid, pid);
|
|
}
|
|
|
|
-int stime(const time_t *t)
|
|
-{
|
|
- struct timeval tv;
|
|
- tv.tv_sec = *t;
|
|
- tv.tv_usec = 0;
|
|
- return settimeofday(&tv, NULL);
|
|
-}
|
|
-
|
|
int sethostname(const char *name, size_t len)
|
|
{
|
|
return syscall(__NR_sethostname, name, len);
|
|
diff --git a/util-linux/rdate.c b/util-linux/rdate.c
|
|
index 70f829e7f..878375d78 100644
|
|
--- a/util-linux/rdate.c
|
|
+++ b/util-linux/rdate.c
|
|
@@ -95,9 +95,13 @@ int rdate_main(int argc UNUSED_PARAM, char **argv)
|
|
if (!(flags & 2)) { /* no -p (-s may be present) */
|
|
if (time(NULL) == remote_time)
|
|
bb_error_msg("current time matches remote time");
|
|
- else
|
|
- if (stime(&remote_time) < 0)
|
|
+ else {
|
|
+ struct timespec ts;
|
|
+ ts.tv_sec = remote_time;
|
|
+ ts.tv_nsec = 0;
|
|
+ if (clock_settime(CLOCK_REALTIME, &ts) < 0)
|
|
bb_perror_msg_and_die("can't set time of day");
|
|
+ }
|
|
}
|
|
|
|
if (flags != 1) /* not lone -s */
|