mirror of
https://git.in.rschanz.org/ryan77627/guix.git
synced 2024-11-07 15:36:20 -05:00
3a2efbc867
Fixes <https://bugs.gnu.org/37468>. * gnu/packages/patches/python-libxml2-utf8.patch: New file. * gnu/local.mk (dist_patch_DATA): Add it. * gnu/packages/xml.scm (python-libxml2/fixed): New variable. * gnu/packages/glib.scm (itstool/fixed): New variable. * gnu/packages/gnome.scm (gnumeric)[native-inputs]: Use ITSTOOL/FIXED instead of ITSTOOL.
40 lines
1.4 KiB
Diff
40 lines
1.4 KiB
Diff
This patch fixes a crash in the libxml2 bindings for Python 3.x
|
|
that 'itstool' stumbles upon when processing UTF-8 data:
|
|
|
|
https://issues.guix.gnu.org/issue/37468
|
|
|
|
Patch by Jan Matejek
|
|
from <https://bugzilla.opensuse.org/show_bug.cgi?id=1065270>.
|
|
|
|
--- libxml2-2.9.5.orig/python/libxml.c
|
|
+++ libxml2-2.9.5/python/libxml.c
|
|
@@ -1620,6 +1620,7 @@ libxml_xmlErrorFuncHandler(ATTRIBUTE_UNU
|
|
PyObject *message;
|
|
PyObject *result;
|
|
char str[1000];
|
|
+ unsigned char *ptr = (unsigned char *)str;
|
|
|
|
#ifdef DEBUG_ERROR
|
|
printf("libxml_xmlErrorFuncHandler(%p, %s, ...) called\n", ctx, msg);
|
|
@@ -1636,12 +1637,20 @@ libxml_xmlErrorFuncHandler(ATTRIBUTE_UNU
|
|
str[999] = 0;
|
|
va_end(ap);
|
|
|
|
+#if PY_MAJOR_VERSION >= 3
|
|
+ /* Ensure the error string doesn't start at UTF8 continuation. */
|
|
+ while (*ptr && (*ptr & 0xc0) == 0x80)
|
|
+ ptr++;
|
|
+#endif
|
|
+
|
|
list = PyTuple_New(2);
|
|
PyTuple_SetItem(list, 0, libxml_xmlPythonErrorFuncCtxt);
|
|
Py_XINCREF(libxml_xmlPythonErrorFuncCtxt);
|
|
- message = libxml_charPtrConstWrap(str);
|
|
+ message = libxml_charPtrConstWrap(ptr);
|
|
PyTuple_SetItem(list, 1, message);
|
|
result = PyEval_CallObject(libxml_xmlPythonErrorFuncHandler, list);
|
|
+ /* Forget any errors caused in the error handler. */
|
|
+ PyErr_Clear();
|
|
Py_XDECREF(list);
|
|
Py_XDECREF(result);
|
|
}
|