mirror of
https://git.in.rschanz.org/ryan77627/guix.git
synced 2024-11-15 03:15:09 -05:00
de98f4ed55
* gnu/packages/crypto.scm (crypto++): New variable. * gnu/packages/patches/crypto++-fix-dos-in-asn.1-decoders.patch: New file. * gnu/local.mk (dist_patch_DATA): Add it. Co-authored-by: Ricardo Wurmus <rekado@elephly.net>
65 lines
1.8 KiB
Diff
65 lines
1.8 KiB
Diff
From 3d9181d7bdd8e491f745dbc9e34bd20b6f6da069 Mon Sep 17 00:00:00 2001
|
|
From: Gergely Nagy <ngg@tresorit.com>
|
|
Date: Wed, 14 Dec 2016 13:19:01 +0100
|
|
Subject: [PATCH] Fix possible DoS in ASN.1 decoders (CVE-2016-9939)
|
|
|
|
---
|
|
asn.cpp | 10 ++++++++++
|
|
asn.h | 2 ++
|
|
2 files changed, 12 insertions(+)
|
|
|
|
diff --git a/asn.cpp b/asn.cpp
|
|
index 297ff010..2e923ef7 100644
|
|
--- a/asn.cpp
|
|
+++ b/asn.cpp
|
|
@@ -123,6 +123,8 @@ size_t BERDecodeOctetString(BufferedTransformation &bt, SecByteBlock &str)
|
|
size_t bc;
|
|
if (!BERLengthDecode(bt, bc))
|
|
BERDecodeError();
|
|
+ if (bc > bt.MaxRetrievable())
|
|
+ BERDecodeError();
|
|
|
|
str.New(bc);
|
|
if (bc != bt.Get(str, bc))
|
|
@@ -139,6 +141,8 @@ size_t BERDecodeOctetString(BufferedTransformation &bt, BufferedTransformation &
|
|
size_t bc;
|
|
if (!BERLengthDecode(bt, bc))
|
|
BERDecodeError();
|
|
+ if (bc > bt.MaxRetrievable())
|
|
+ BERDecodeError();
|
|
|
|
bt.TransferTo(str, bc);
|
|
return bc;
|
|
@@ -161,6 +165,8 @@ size_t BERDecodeTextString(BufferedTransformation &bt, std::string &str, byte as
|
|
size_t bc;
|
|
if (!BERLengthDecode(bt, bc))
|
|
BERDecodeError();
|
|
+ if (bc > bt.MaxRetrievable())
|
|
+ BERDecodeError();
|
|
|
|
SecByteBlock temp(bc);
|
|
if (bc != bt.Get(temp, bc))
|
|
@@ -188,6 +194,10 @@ size_t BERDecodeBitString(BufferedTransformation &bt, SecByteBlock &str, unsigne
|
|
size_t bc;
|
|
if (!BERLengthDecode(bt, bc))
|
|
BERDecodeError();
|
|
+ if (bc == 0)
|
|
+ BERDecodeError();
|
|
+ if (bc > bt.MaxRetrievable())
|
|
+ BERDecodeError();
|
|
|
|
byte unused;
|
|
if (!bt.Get(unused))
|
|
diff --git a/asn.h b/asn.h
|
|
index ed9de52c..33f0dd09 100644
|
|
--- a/asn.h
|
|
+++ b/asn.h
|
|
@@ -498,6 +498,8 @@ void BERDecodeUnsigned(BufferedTransformation &in, T &w, byte asnTag = INTEGER,
|
|
bool definite = BERLengthDecode(in, bc);
|
|
if (!definite)
|
|
BERDecodeError();
|
|
+ if (bc > in.MaxRetrievable())
|
|
+ BERDecodeError();
|
|
|
|
SecByteBlock buf(bc);
|
|
|