guix/gnu/packages/patches/ibus-anthy-fix-tests.patch
Maxim Cournoyer 4e60cbe5bb
gnu: ibus-anthy: Prepare for tests.
* gnu/packages/patches/ibus-anthy-fix-tests.patch: New patch.
* gnu/packages/ibus.scm (ibus-anthy): Register it.
* gnu/packages/ibus.scm (ibus-anthy) [source]: Apply patch.
[arguments]: Clarify #:tests? comment.  Add a fix-check,
do-not-override-GI_TYPELIB_PATH and prepare-for-tests phases.
[native-inputs]: Add procps, python-pycotap, util-linux and
xorg-server-for-tests.
2023-06-14 11:05:30 -04:00

49 lines
1.3 KiB
Diff

Submitted upstream: https://github.com/ibus/ibus-anthy/pull/35
diff --git a/tests/test-build.sh b/tests/test-build.sh
index e83b78f..a0efe32 100755
--- a/tests/test-build.sh
+++ b/tests/test-build.sh
@@ -63,26 +63,27 @@ parse_args()
done;
}
+maybe_install_pycotap() {
+ # Check if pycotap is already available.
+ python3 -m pycotap >/dev/null && return 0
+
+ # Red Hat specific hint.
+ if test -f /etc/redhat-release ; then
+ if ! rpm -q --quiet python3-pycotap; then
+ echo "Please install python3-pycotap"
+ exit -1
+ fi
+ fi;
+}
+
init_environment()
{
if test x$FORCE_TEST != x ; then
RUN_ARGS="$RUN_ARGS --force";
fi;
- HAS_TAP=0;
- if test -f /etc/redhat-release ; then
- rpm -q --quiet python3-pycotap
- if test $? -ne 0 ; then
- echo "Not found python3-pycotap";
- exit -1;
- fi;
- HAS_TAP=1;
- fi;
- TAP_DIR=`python -m site --user-site`/pycotap;
- if test $HAS_TAP -ne 1 && \
- test x"$TAP_DIR" != x && test ! -d "$TAP_DIR" ; then
- echo "pip install pycotap --user";
- pip install pycotap --user;
- fi;
+
+ maybe_install_pycotap
+
if test ! -f $BUILDDIR/../data/$ANTHY_SCHEMA_FILE ; then
echo "Not found $BUILDDIR/../data/$ANTHY_SCHEMA_FILE";
exit -1;