guix/gnu/packages/patches/python-shiboken-2-compat.patch
Josselin Poiret 9e81b4da2d
gnu: python-shiboken-2: Do not rely on _Py_Mangle being available.
* gnu/packages/patches/python-shiboken-2-compat.patch: Fix the patch
according to upstream.

Signed-off-by: Andreas Enge <andreas@enge.fr>
2023-04-24 12:46:42 +02:00

15 lines
679 B
Diff

Backport a fix from 5.15.9, mentioned in [1].
[1] https://bugreports.qt.io/browse/PYSIDE-2176
--- pyside-setup-opensource-src-5.15.8/sources/shiboken2/libshiboken/pep384impl.cpp 2023-04-24 11:05:48.770934499 +0200
+++ pyside-setup-opensource-src-5.15.8/sources/shiboken2/libshiboken/pep384impl.cpp 2023-04-24 11:04:51.566943936 +0200
@@ -751,7 +751,7 @@
#endif // IS_PY2
Shiboken::AutoDecRef privateobj(PyObject_GetAttr(
reinterpret_cast<PyObject *>(Py_TYPE(self)), Shiboken::PyMagicName::name()));
-#ifndef Py_LIMITED_API
+#ifdef IS_PY2
return _Py_Mangle(privateobj, name);
#else
// PYSIDE-1436: _Py_Mangle is no longer exposed; implement it always.